PDA

View Full Version : Error! Unable to forward port via UPnP


Madeo
2004-11-16, 16:36
Whenever I try to dl, I get this error above the pause button in the bittorrent thing.
Couldn't listen-Unable to forward port via UPnP

What's wrong what can I do?

AnimeOni
2004-11-17, 03:15
Basically, the client you are using is trying to enable the correct ports for BT traffic and it's having problems.

Most of the time, it's the router. You probably have a Dlink,Linksys, etc box attached betwen your Internet connection and your computer. If yes,
1. Grab your user manual.
2. Log into your router per the manual.
3. Find the uPnP selection and enable it.
-> Note, some older routers requires you to upgrade the firmware.
4. If this doesn't help, go to http://portforwarding.com for model specific forwarding.

If you cannot enable uPnP, you need to manually forward the ports 6991-6999 to your local system IP.

Madeo
2004-11-17, 14:44
Yeah, I just got a new router...but the user manual doesn't say anything about uPnP and the link doesn't work, but I have an adsl modem which goes to the router. If I connect the model directly to the pc, instead of via the router, is there a chance that it might work? And will it work if I take my pc to some guy whom bittorrent works? I'm just looking for this anime series, but it's rather long and would require like 50 cd's for all the episodes, so I'd rather dl it.

AnimeOni
2004-11-17, 23:52
If you can tell us what router you have, we might be able to help you. If you connect directly to the Internet without the router, then you do not have to do the port forwarding stuff unless the ADSL router itself (some do have NAT) blocks you. then you are back to square one.

Ayanami9870
2005-12-29, 06:48
If UPnP is enabled on the router, but bittorent still won't go, just reboot the router and it should be happy again. Make sure you write down all of the important security settings and port triggers before doing so. Once that's done, unplug the router, go to the back of it and using a pencil, depress a small reset button while replugging the router in. The status lights will flash and the problem should be gone. After you reconfigure the router, you're ready to go again.

Siol57
2007-08-03, 02:56
Instead of rebooting the router you can just turn UPnP off and then switch it back on again... That cleared up the problem and is much less hassle than reseting your router.

SeijiSensei
2007-08-03, 08:39
If I connect the mode[m] directly to the pc, instead of via the router, is there a chance that it might work?

Do not do this unless you have a well-configured software firewall running on your computer. Otherwise your computer may be open to various attacks over the Internet. The router isn't just "routing;" it also has a firewall that protects the machines behind it from these types of attacks.

Evidence from testing indicates that many Windows PC's, especially ones without the full set of security upgrades and patches, can be infected in less than half an hour (http://www.gcn.com/online/vol1_no1/26967-1.html) if connected directly to the Internet without a firewall.