AnimeSuki.com Forum

AnimeSuki Forum (http://forums.animesuki.com/index.php)
-   Forum & Site Feedback (http://forums.animesuki.com/forumdisplay.php?f=2)
-   -   Feedback: New BB Codes: Dynamic Loading (http://forums.animesuki.com/showthread.php?t=110486)

NightWish 2012-02-21 18:28

New BB Codes: Dynamic Loading
 
A little while ago I added a BB code to allow niconico videos to be posted. At the same time a number of other codes, in the same vein, were added but were not publicised.

I and the other staff have been testing them in the background for a while, on different platforms, and think I've got most of the bugs ironed out. There is still at least one issue involving accented (and maybe multi-byte) characters causing the content to be truncated, and some others noted in the samples below.

What I've not done yet is test them in a truly wide and representative range of browsers... which I'm hoping everyone here can do for me :).

Theses are all now "public" beta if you like; so please have a look and provide some feedback. Note: they are all still subject to change and possibly complete removal. That means you might not want to use them in the wider forum without also considering what would happen if they were disabled.

Dynamic tag cannot be rendered. (PrintableThread)
Before anyone asks: No, you can't use these tags in your signature, but yes, they should work in PMs, and unless something is broken, social groups... should you want to. Only thing to note: if you use quick reply or quick edit (the in-line post edit) you may need to click (the button or the re-enable message) to "re-enable" the dynamic functionality. This happens because the forum doesn't provide a way to extend the updates to the page, that happen after you post in those two cases. I'll spare you the details. This is unlikely to be made more user friendly until the forum is upgraded, because it will likely change when the forum is upgraded (and thus anything I do now will need redoing). It is a minor irritation.

If you want to report the codes not working, please do so here. Be sure to include a note about your browser version and possibly operating system version too. It will help track down the incompatibilities (though I can't promise we'll be able to resolve them). All tags require JavaScript to function, lack of it means you'll just get a "need JavaScript" grey box. Oh, and if you're using IE 6 please stop.

Dynamic tag cannot be rendered. (PrintableThread)

blaze0041 2012-03-01 23:38

Reporting an issue I'm having with the [images] tag in this post (actually seems to be occurring with the other new beta tags as well), specifically this part:
Code:

[spoiler="Azusa, Ui, and Jun's graduation"][URL=http://imgur.com/FxpY4][IMG]http://i.imgur.com/FxpY4l.jpg[/IMG][/URL]

[B][URL="http://p.tl/i/25477114"]梓 憂 純 卒業[/URL][/B]
純「梓、あんた今ヘンなこと考えてるでしょ?」
梓「え?」
純「ダメだよ、何度も話したよね?梓はこっから先は放課後ティータイムになるんだよ」
梓「でも」
憂「私も純ちゃんも、梓ちゃんのいる放課後ティータイムのファンだから」
純「気なんて遣わなくていい。私たちはずっと梓のこと見て、応援するよ」
梓「うん」

卒業のシーンかそれより前に、こんなシリアスな展開もあるんじゃないかと妄想です。
放課後ティータイムとわかばガールズの狭間で葛藤する梓(ないとは思いますが)
※昨年12月に上げようとして結局頓挫している和誕マンガを投稿した際に削除予定です。[/spoiler]

If you replace "spoiler" with one of the new beta tags, then it gets truncated at the same point...
Spoiler for examples:


Using Windows 7 Ultimate (64-bit, Service Pack 1), Firefox 10.0.2. Also tested on Chrome and Internet Explorer 9.
Though it seems the problem fixes itself if you use the in-line post editor and edit a post, then forcing the beta tags to reload the dynamic content. The issue comes back if you use the "go advanced" edit post option.
Speaking of IE, it doesn't play very nicely with the [TABLE] tag right now...

Masuzu 2012-03-02 06:16

Very cool, I look forward to seeing the day most if not all of these become commonplace.

NightWish 2012-03-02 17:45

1 Attachment(s)
Quote:

Originally Posted by blaze0041 (Post 4034449)
Reporting an issue I'm having with the [images] tag ...

Thanks; seems to be dropping at "…". I'll see if I can debug and resolve the issue using your post as a test case.

Edit: Even more sure it is an encoding issue now... The forum I tested it on was using UTF-8 end-to-end. There the post works fine in the tag, but not outside~ :eyespin: The in-line edit doesn't work for it (again only outside the tags) and the advanced edit causes the post to appear on first viewing. Bizarre.

Hiroi Sekai 2012-03-02 18:49

Have been noticing these around the forums lately. Looks quite nice, thanks for the additions.:heh:

monster 2012-03-03 18:59

Great, they seem to be working with IE10.
Quote:

Originally Posted by NightWish (Post 4018167)
New settings: Auto Open
Some of the tags above automatically open. You should be able to tell which do and which do not. I think it is just the videos at the moment.

The alternative quote tag seems to automatically open as well, for an obvious reason.

Larthak 2012-03-06 12:42

Looks amazing; clean and simple. Seems to work well (no issues so far). I'll be sure to test it whenever I find the opportunity.

blaze0041 2012-03-12 03:15

Something else I've come across, mainly in regards to the spoiler tag (both new and old versions) and the (misc.) posting option "Automatically parse links in text".
For example:
Dynamic tag cannot be rendered. (PrintableThread) Dynamic tag cannot be rendered. (PrintableThread) In this case, only example2 and example3 have their links automatically parsed, whilst example1 does not.

Eisdrache 2012-03-13 21:31

Please excuse me if I missed this somewhere (it's 3am after all ;_; ) but isn't TL;DR pretty much a spoiler tag that doesn't need a reason?

relentlessflame 2012-03-13 22:39

Quote:

Originally Posted by Eisdrache (Post 4051650)
Please excuse me if I missed this somewhere (it's 3am after all ;_; ) but isn't TL;DR pretty much a spoiler tag that doesn't need a reason?

Well, they're almost all "pretty much a spoiler tag", but they mean different things. People have been using spoiler tags for a lot of different purposes for a while now that aren't actually spoilers, and that just confuses matters and gets people in the habit of opening spoiler tags without thinking there'll be spoilers inside them. So, with these new tags, the hope is that people will use the right tag that properly describes what's inside. If you're going to include a (permitted) spoiler, you'd have to use a real spoiler tag. But if you want to mask a NSFW image or something, you should not use a spoiler tag (because it's not a spoiler).

So yeah, they all sort of work like spoiler tags in a way, but they're to cover uses beyond just spoilers.

NightWish 2012-03-14 15:04

Quote:

Originally Posted by blaze0041 (Post 4048871)
Something else I've come across...

It is a peculiarity of the the parser the forum uses. That's why it happens with the original spoiler tag too (which is completely independent of the new tags). Next time I make a change to them I'll see if I can work around it.

thirdlc 2012-03-21 04:24

Images, Quote, Spoilers, YouTube and NicoNico tags don't work on pages appended by AutoPagerize extension. Fedora 16, Chrome 17.0.963.79, AutoPagerize 0.3.4

relentlessflame 2012-03-21 09:09

Quote:

Originally Posted by thirdlc (Post 4063696)
Images, Quote, Spoilers, YouTube and NicoNico tags don't work on pages appended by AutoPagerize extension. Fedora 16, Chrome 17.0.963.79, AutoPagerize 0.3.4

This is just me, but I tend to think that it would be up to the person who codes the extension to write it such a way that doesn't break code that works just fine without the extension. If we try to fix it, it's possible the extension could change again later and it would break again. In the meantime, I think it's just "you shouldn't use that extension", for now...

thirdlc 2012-03-22 04:17

Quote:

Originally Posted by relentlessflame (Post 4064076)
This is just me, but I tend to think that it would be up to the person who codes the extension to write it such a way that doesn't break code that works just fine without the extension. If we try to fix it, it's possible the extension could change again later and it would break again. In the meantime, I think it's just "you shouldn't use that extension", for now...

Thanks. OK, I don't want to sacrifice comfort of AutoPagerize, so I'll open the post in a new tab if needed.

I've tested AutoPager Chrome and AutoPatchWork, too. But with them, those new tags didn't work. The three extensions I tested remove script tags and source in them in the appended pages. Out of curiosity, why do contents have to be builded dynamically with javascript? If only the new tags' function were simple hide & show.

relentlessflame 2012-03-22 08:32

Quote:

Originally Posted by thirdlc (Post 4065782)
Out of curiosity, why do contents have to be builded dynamically with javascript?

Because loading the content on request was one of the improvements we were trying to achieve. Right now, people sometimes use the old spoiler tags to hide large and/or NSFW images, but most browsers will load them anyway even if they're not shown. Some people mistakenly think that hiding them inside the old-style spoiler tags will save on bandwidth, but it generally doesn't. So, with the new style tags, it does do that; only when you click the tag does it load the contents. That's what we wanted it to do in this case.

NightWish 2012-03-23 14:44

The only thing I will add to relentlessflame's reply is that even if we could have created the tags without javascript, the NicoNico tag (i.e. the tag request that prompted the creation of new tags in the first place) requires it. They don't offer an alternative, unlike YouTube for example.

Suomi 2012-03-28 13:50

Did this go away? :confused:
Or do I need to do something to make it work? I can't seem to use them...they don't even appear in the text options when I go to make a post...
I'm using Firefox (don't know what version or how to figure that out.) and Windows 7...

relentlessflame 2012-03-28 14:32

Quote:

Originally Posted by Illusore (Post 4078996)
Did this go away? :confused:
Or do I need to do something to make it work? I can't seem to use them...they don't even appear in the text options when I go to make a post...
I'm using Firefox (don't know what version or how to figure that out.) and Windows 7...

I don't think they've ever shown up in the editor (i.e. there are no buttons for it yet), but you can just type them in your post manually. It's working for me in Firefox 10 and 11, so not sure...

Suomi 2012-03-28 22:16

Quote:

Originally Posted by relentlessflame (Post 4079057)
I don't think they've ever shown up in the editor (i.e. there are no buttons for it yet), but you can just type them in your post manually. It's working for me in Firefox 10 and 11, so not sure...

oh, I see. Gotcha. Works now.

totoum 2012-03-31 03:25

Seems like I've got a problem with the new youtube tag.

If I use the new one I get this:

Dynamic tag cannot be rendered. (PrintableThread)

But if I use the old one it works:



All times are GMT -5. The time now is 06:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.