AnimeSuki.com Forum

AnimeSuki Forum (http://forums.animesuki.com/index.php)
-   Forum & Site Feedback (http://forums.animesuki.com/forumdisplay.php?f=2)
-   -   Forum Server Move (February 8, 2010) (http://forums.animesuki.com/showthread.php?t=91303)

GHDpro 2010-02-08 02:49

Forum Server Move (February 8, 2010)
 
The AnimeSuki forums moved servers on February 8, 2010. If you're reading this than you're already viewing the forum from the new server.

The last time we moved (almost exactly 2 years ago in February 2008) it was because of financial reasons - the new server back then was a lot cheaper than our old one. This time the new server is also cheaper as the last one, but not by much ($5/month).

The main reason for the move this time was that after two years I felt that it would be possible to get a better server for less, and I think I've succeeded in finding in such a server.

The old server specs were:
- Core2Duo E6600 (dual core)
- 6 GB RAM
- 2x 74GB 10K RPM SATA (Raptor) drives in hardware RAID-1
- Location: Chicago, Illinois, USA

The new server specs are:
- Core i7 860 (quad core)
- 16 GB RAM
- 4x 146GB 15k RPM SAS in hardware RAID-10
- Location: Los Angeles, California, USA

As you can see the difference in specs is quite amazing :D The only downside is that the server is now physically located further away from the US east coast and Europe, which might cause a bit more latency. But hopefully the incredible increase in server power will make up for this.

Together with the hardware change I've also changed some things on software level. Although I hope there won't be any problems with this, there may be some issues. If you notice some things are not working anymore as expected, please post in this thread.

felix 2010-02-08 04:41

Quote:

Originally Posted by GHDpro (Post 2905031)
The only downside is that the server is now physically located further away from the US east coast and Europe, which might cause a bit more latency.

I think that's probably only something one should ever worry about in MMO games.
Quote:

Originally Posted by GHDpro (Post 2905031)
Together with the hardware change I've also changed some things on software level.

Server software? or forum software?

GHDpro 2010-02-08 04:46

Quote:

Originally Posted by Cats (Post 2905089)
Server software? or forum software?

Server software. Old server ran CentOS with custom packages for lighttpd, PHP and MySQL. New server runs Debian (5.0) with standard packages for everything (which means way easier upgrading). On the web serving side, we used lighttpd with PHP FastCGI before and now it's nginx as a proxy in front of Apache (nginx handles all static content, Apache all PHP scripts). Last, I changed the location of the forum on the file system so some paths needed to be updated.

The only change on forum software level is that we're now running the latest vBulletin v3.x again (v3.8.4 PL2). Before we were one patch level behind. In other words, not really a major change.

felix 2010-02-08 04:52

Issue #1. I just got the announcement thing on top about "moving servers..." now and not before seeing this thread. Which popped up to me right at the time of my post (ie. 2h after the first post -- gonna presume the post was made beforehand).

GHDpro 2010-02-08 04:54

That notice was set to run at 9:50 UTC. Which er.... means I ran the upgrade one hour early by mistake :heh:

Oh well down time was only ~30 minutes anyway...

(I've removed both the notice and announcement btw)

GHDpro 2010-02-12 08:28

Many companies already seem to have reserved IPv6 address blocks, but I don't think many companies are ready to roll out IPv6 to their customers.

Anyway, I couldn't find any info on their website about IPv6 so I've opened a ticket with support to ask what their IPv6 readiness is.

Edit:
Wow, fast response despite it being late evening/middle of the night in LA right now. Maybe the tech was bored :)

Anyway their response:
Quote:

Hello, we currently have ipv6 running on a few test subnets, at this point we expect to roll it out to all clients by the middle of this year.
So, IPv6 support for the AnimeSuki forum should hopefully be possible sometime 2010.

Mentar 2010-02-12 08:59

Thank you very much for the fine service you're providing ;)

Very much appreciated!

NightWish 2010-02-12 12:52

Quote:

Originally Posted by GHDpro (Post 2911801)
So, IPv6 support for the AnimeSuki forum should hopefully be possible sometime 2010.

It is a while since I checked the support, but I think that would also require us upgrading the forum to v4.0; I don't think 3.x supports IPv6 without custom modification.

NightWish 2010-02-12 18:08

Quote:

Originally Posted by The Small One (Post 2912559)
Why?

Without looking too deeply into the software myself, I would assume for the following reason: it is written in PHP and assumes it is running on a web server that is attached to an IP based network. Specifically it assumes that all users accessing the forum have IPv4 addresses. Anything in the software that uses IP addresses for tracking "stuff" (session structures, various database table fields (e.g. the post table), banning logic, etc.) all needs to be updated to allow for the larger address size (and formats, i.e dotted decimal will no longer cut it).

felix 2010-02-13 04:07

Quote:

Originally Posted by The Small One (Post 2913147)
BTW, are we still on-topic?

Technically you are discussing moving servers to IPv6, so yes.

NightWish 2010-02-13 07:50

Quote:

Originally Posted by The Small One (Post 2913147)
I found some sort of mod, which replaces truncated adresses by hashed ones.

Yeah, I know it is possible (if not that mod there are other examples out there), but they all require changes that we don't want to have to support. More so when the official release of v4 should support it...
Quote:

Originally Posted by Cats (Post 2913165)
Technically you are discussing moving servers to IPv6, so yes.

We're drifting from the "Server Move" (singular, specific) topic, and in fact now venturing into meta-discussion, so lets stop.

GHDpro 2010-11-09 04:44

Sorry, sadly there is no change -- we've heard from neither our forum provider (WebNX, California) nor site provider (Server Connect, Sweden) regarding IPv6 support, other than "they're working on it".

In the mean while, one of my other sites (The Emulator Zone) is 100% IPV6 ready, as it's hosted by FDC Servers which has supported IPv6 for years and ImageHost.org could be made IPv6 ready once I request a IPv6 block from 100tb.com/Softlayer.

Also, though I did have to buy my own IPv6 ready modem for it, I'm also running native IPv6 at home (www.test-ipv6.com returns 10/10 scores for both IPv4 & IPv6 for me).

Anyway, I'd like to wait a little longer (until early 2011) when the final IP blocks are (nearly) gone to ask again. I can't imagine the ISPs not being aware than IPv4 depletion will hit them the hardest first.


All times are GMT -5. The time now is 23:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.