AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2007-12-02, 10:34   Link #1
HeavensNight
Junior Member
 
Join Date: Dec 2007
Media Player Classic subtitle scaling problem

Before we begin, let me just make it clear that I've pretty much got my computer set up to play back any kind of file. All of my codecs are kept to a necessary minimum and I proactively monitor my registry for superfluous codecs and potential conflicts, so I'm no neophyte when it comes to this sort of thing.

However, my main problem, while not preventing me from watching what I want, is slightly annoying. Observe the following:

Spoiler for Screenshot:


The above screenshot looks pretty normal, right? The problem shows itself when I try to watch that in fullscreen:

Spoiler for Screenshot:


See how the subtitles are no longer in their original positions? It's scaling the subtitles so that they fit the fullscreen dimension instead of fitting to the relative video size. Is there a way to fix this? I'd rather not use WMP or ZoomPlayer.
HeavensNight is offline   Reply With Quote
Old 2007-12-02, 11:53   Link #2
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 28
It's caused by MPC's internal subtitles renderer drawing subtitles relative to your entire screensize instead of doing it relative to the frame size, as the typesetter did.

There are two possible solutions:
1) disable MPC's internal subtitles renderer and use the external VSFilter instead (preferably the version shipped with the CCCP). This is probably the better option since VSFilter is at least slightly maintained while MPC is pretty much dead at this point. It's also the most "compatible" solution.
This will help because VSFilter always draws directly on the frame immediately after decoding, not after rendering the video frame on screen like MPC's renderer does.

2) in MPC, go view -> options -> subtitles -> default style, and tick the box "position subtitles relative to the video frame". (It's in the upper right corner under "screen alignment and margins".) This option may or may not be present depending on MPC version.


Edit: by the way, this is a nice example of why it's a good idea even for people who know what they are doing to use the CCCP; some quirks are just plain obfuscated. :V
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline   Reply With Quote
Old 2007-12-02, 19:30   Link #3
HeavensNight
Junior Member
 
Join Date: Dec 2007
I was looking over that dialogue once but didn't think to mess with the checkbox yet, thanks for the working piece of advice. I was already using CCCP, by the way.
HeavensNight is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 13:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.