AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2008-08-13, 09:54   Link #1
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
MPlayer OSX Extended

The posts are a bit unorganized and conflict with their threads' actual topic so I'll start a fresh one here.

Development on the MPlayer OSX frontend hasn't been very active and after putting my nose int the source I just couldn't resist doing something about it.

Currently, the added features are most notably:
  • More video filter options (Postprocessing, Deinterlace etc)
  • Support for styled ASS subtitles
  • Audio and video equalizers (not yet interactive)
  • Taking Screenshots
  • Stream selection
  • Various interface improvements

The current version is revision 6 and you can find it on the homepage:
http://mplayerosx.sttz.ch/

Comments, feature requests and but requests are welcome here, or per email.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.

Last edited by anime_layer; 2009-03-11 at 17:43.
anime_layer is offline   Reply With Quote
Old 2008-08-13, 09:55   Link #2
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
I just released revision 5. Here's quick rundown on the changes:

New Features:
  • Stream selection
    The gui will detect video and audio streams as well as internal subtitle streams and external subtitle files. Those streams can be selected and switched as the movie is playing. Currently, if no stream is explicitly selected with -sid,-aid,-vid or -slang,-alang, mplayer will not report which stream it has chosen and the gui cannot display the selection. Though as soon as you select a stream, it will reflect that in the menus.
  • ASL Logging
    The code had been using NSLog() for all it's logging and redirected the output to a logfile. In Leopard, that redirection didn't work anymore as all message were also sent to system.log. I've now switched to ASL. All messages are now logged to ~/Library/Logs/MPlayerOSX.log, while critical messages are also logged to system.log
  • New Icon
    I couldn't find any good hi-res source of the current icon and I liked the one from the Tango Project, which is available in glorious SVG.
  • New Name
    I decided to change the name of my revision to "MPlayer OSX Extended". The goal is still to feed as many changes as possible back to the original project but I guess there will be always a place for a version from the most current SVN. Also, this way, both versions can live happily side-by-side on the same system.
Improvements:
  • Video View ("MPlayer OSX" video output only)
    When switching videos, the video view was always closing and reopening. I fixed it to stay open if playback is not stopped but just switching to another video. This works for opening video files as well as the playlist.
  • Playlist
    When dragging a video to the playlist, any playback was being interrupted. MPlayer OSX now uses an own mplayer instances to do preflights so adding and playing can be done at the same time. Also, the GUI no longer flickers when doing a preflight and MPlayer remembers if the playlist was opened when it quit.
  • Volume
    It's no possible to mute and un-mute audio by clicking on the volume icon. There are also new menu items and keyboard shortcuts for changing the volume. Also, when changing volume in mplayer (using 9 and 0, normally), the change will be picked up by the GUI.
  • Menu Controls
    Playback and playlist commands are now accessible as menus and have keyboard shortcuts assigned to them. Also, Command-W now works for closing the main window and the playlist.
  • Screenshots
    Taking screenshots was broken in the last revision due to a bug in the configure script. Not it's working again (yay! my first patch!).

The current revision is available here: http://mplayerosx.sttz.ch/
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.

Last edited by anime_layer; 2008-08-13 at 10:19.
anime_layer is offline   Reply With Quote
Old 2008-08-16, 01:41   Link #3
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
I love you.

Hm... weird behaviour. When I shift focus to or from the MPlayer window, the screen flashes black for a split moment. Same if I invert the colours (Cmd+Opt+Ctrl+8) while the player is the active window. If I do either of these things while the video is paused, it stays black (or white inverted :P) until I unpause.

UPDATE: This is only if MPlayer OSX is the video out being used. I suppose it probably has to do with whatever is being done to make the window not resize down to controller size after a "restart" caused by changing preferences. Also, this probably isn't a priority (since who would really do this? :P), but if I change video out modes in the middle of playing a file in MPlayer OSX mode (CoreVideo in this case), it works, but the old playback windows stays the same size it was before instead of shrinking down to a controller.

Last edited by Discerptor; 2008-08-19 at 23:12.
Discerptor is offline   Reply With Quote
Old 2008-08-18, 17:48   Link #4
GreenyOSX
Junior Member
 
Join Date: Aug 2008
Wow, finally, after all this time, subtitles work in MPlayer! ^^

But... Uh... I seem to be having problems. You see, the video is not
in sync with the audio - It seems to be going at a lower frame rate
than it's supposed to. If anyone can tell me how to fix this, I'd be
forever grateful. No really, seriously.
GreenyOSX is offline   Reply With Quote
Old 2008-08-18, 17:49   Link #5
Hellion314
Junior Member
 
Join Date: Aug 2008
Thanks for the release. I like the new GUI.
Hellion314 is offline   Reply With Quote
Old 2008-08-18, 18:30   Link #6
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Quote:
Originally Posted by GreenyOSX View Post
Wow, finally, after all this time, subtitles work in MPlayer! ^^

But... Uh... I seem to be having problems. You see, the video is not
in sync with the audio - It seems to be going at a lower frame rate
than it's supposed to. If anyone can tell me how to fix this, I'd be
forever grateful. No really, seriously.
Subtitles have worked in MPlayer for quite some time, and in fact it has been the best option on OS X for softsubs for just as long. As for the video sync, your computer is probably too slow to play the file in question. What Mac do you have, and what's the file you're trying to play?
Discerptor is offline   Reply With Quote
Old 2008-08-19, 01:18   Link #7
SPC1st
Junior Member
 
Join Date: Oct 2004
Awesome work with this release - now I can play external subtitles with ease (for some reason, the auto-detection doesn't work for me in the normal MPlayer build)! A quick question, however: is it possible to change the color of the external subs? It comes out as yellow, but I've really gotten too used to white subtitles that the yellow ones have become sort of an eyesore. I've looked through the original MPlayer documentation without much success.
SPC1st is offline   Reply With Quote
Old 2008-08-19, 08:55   Link #8
GreenyOSX
Junior Member
 
Join Date: Aug 2008
Quote:
Originally Posted by Discerptor View Post
Subtitles have worked in MPlayer for quite some time, and in fact it has been the best option on OS X for softsubs for just as long. As for the video sync, your computer is probably too slow to play the file in question. What Mac do you have, and what's the file you're trying to play?
Actually, in normal MPlayer, I press the right button but it doesn't
show the subtitles and I have no clue how to make it work. I heard
there's a way via the command line, but I have no clue how to make
That work. ^_^" It only really works in this version.


And it's definately not my computer! I gots a PPC G4, y'know! >:O
Running Tiger, and the file's an mkv. Well, it's pretty much the
Same with all mkv's. Also, I can play it in normal MPlayer perfectly,
just no subs; that's why I'm sure it's not my computer. And
the audio plays perfectly, too.

And, about mkv's, rarely do they work normal with VLC, and if they do,
I'm fine with that, but most mkv's are heavily choppy, laggy, or
even just not working. Yeah, I know, mkv's only a container, but
I don't care about all that. It works or it doesn't work. That's why
I need MPlayer

That basically sums up my problems. I'm seeing that most newer anime
are all turning mkv, so... PLEAAASE HELP MEEEEEEEE!!! *cry*
GreenyOSX is offline   Reply With Quote
Old 2008-08-19, 09:28   Link #9
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
@Discerptor
There's also the problem that the video halts whenever you press a button or open a menu. If the video output is set to a separate window, then that window runs with the mplayer process separate from the GUI. Otherwise the GUI gets the video through shared memory and does everything in one single thread which I guess causes these problems.

@SPC1st
Try adding this to the command line options in the advanced preferences tab:
Code:
-ass-color ffffff00
(Assuming you have ass subtitles enabled. If so, even non-ass subtitles get rendered by libass).

@GreenyOSX
The GUI puts an additional strain on the CPU. With integrated video the GUI uses about 5% and without about 2% CPU on my machine. Subtitle rendering also uses a bit of CPU power.

So it could be that the video barley plays in the command-line mplayer and doesn't play anymore with the added strain of the gui and subtitles.

Open the activity monitor and check if you CPU is maxed out.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Old 2008-08-19, 12:53   Link #10
GreenyOSX
Junior Member
 
Join Date: Aug 2008
Yeah, it's maxed out. And my normal MPlayer has GUI too -
but when taking a closer look - it's off too. Only less.
So you're probably right. How can I fix this...?
GreenyOSX is offline   Reply With Quote
Old 2008-08-20, 02:13   Link #11
Hellion314
Junior Member
 
Join Date: Aug 2008
I'm kinda having the same problem as GreenyOSX.
The video is lagging to the audio.

I'm on a MacBook Pro
-2.33 Ghz Core 2 Duo
-2 GB 667 Mhz DDR2
-Radeonx1600 256 MB VRAM
-OSX 10.5.4

The video I'm trying to play is a
1280x720 h264

This only happens when I play it on MPlayer and the resolution is that or higher (I guess HD releases). When I play this format on Quicktime w/ Perian it works somewhat fine, there is a slight audio/video pauses. When I checked the activity monitor when its playing on MPlayer, its hitting about 90-94% on process and 40-60 MB on the memory usage.

Last edited by Hellion314; 2008-08-21 at 23:59.
Hellion314 is offline   Reply With Quote
Old 2008-08-21, 12:11   Link #12
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Greeny: Get a new computer or get used to watching the non-HD releases. I had a G4 PowerBook, and it couldn't play any 720p (1280x720 resolution) h264 files without lagging. I suppose you could try what I'm about to mention to Hellion if you want to try one last thing though.

Hellion: You could get a non-expiring infraction for mentioning that file on AnimeSuki forums since that animé is licensed in the U.S. You should edit your post to only mention the resolution and encoding. To play 720p and higher quality h264 files in general, I think your computer has more than enough CPU power for it, so you must be running lots of stuff in the background. Don't do that. If you need more speed still, under the "Video" tab in the preferences, in the "Decoding and Filters" section, make sure the box for Fast libavcodec decoding is checked.
Discerptor is offline   Reply With Quote
Old 2008-08-21, 13:53   Link #13
GreenyOSX
Junior Member
 
Join Date: Aug 2008
I guess you're right. The ones that don't work do seem awfully big screened.
Or 'HD' as you put it. But, how can I find these 'non-HD' releases you speak of?
I just download the anime I can find - which is hard for me as is because
my twisted and evil ISP puts a cap on p2p traffic; so torrents are out
of the question. But, seeing as this forum is awfully strict, you're probably
not allowed to say anyways. Thanks for taking the time to help me with
my problem though.
GreenyOSX is offline   Reply With Quote
Old 2008-08-21, 23:36   Link #14
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Greeny, many fansub groups use IRC channels, which allow you to download files in a non-P2P manner using xdcc. For Mac OS X, I recommend Colloquy (just make sure in the "Interface" tab of the preferences to check the box that says "Show Notices as Private Chat," or the way Growl makes them disappear will annoy you to no end). Usually it's best to find out what groups are subbing the anime you want to watch and go to their website to see what they're releasing - almost every single fansub group I know of releases both a "low quality" and "high quality" version because of the CPU requirements of high-resolution H264 decoding. You can usually find the name/location of their IRC channel in there somewhere too.

Also, on the subject of torrents - with a proper torrent program, you can limit your upload speed to be as low as you need for your ISP to be okay with the outgoing traffic. On Mac OS X, I recommend Transmission above all others. It's lightweight, open source and has an incredibly good GUI.
Discerptor is offline   Reply With Quote
Old 2008-08-22, 00:07   Link #15
Hellion314
Junior Member
 
Join Date: Aug 2008
First I'd like to thank you for the heads up and I apologize about the post.

I tried playing those type of files with only Mplayer running. I also checked that option and tried playing those type of files again and the problem is still the same.
Hellion314 is offline   Reply With Quote
Old 2008-08-22, 15:52   Link #16
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Only two more common things I can think of at the moment: check your Energy Saver Preferences (one of the system preference pane in Mac OS X) to make sure you're not on "Better Energy Savings" mode, and try playing with the different options for framedrop in your MPlayer OSX Extended preferences under the Video tab.

EDIT: Also make sure you're not running on zero free RAM (spotlight for "Activity Monitor")

EDIT: Also try changing the Video Output in the "Display" tab of the MPlayer OSX Extended preferences to CoreVideo and see if that makes a difference.

Last edited by Discerptor; 2008-08-22 at 18:38.
Discerptor is offline   Reply With Quote
Old 2008-08-22, 17:09   Link #17
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
I just released revision 6:
  • Threaded integrated video display
    After getting my head around how to do threading in Cocoa and some of it's shortcomings, I managed to separate the integrated video display into its own thread. This means that opening menus in the GUI will no longer block the video. If you're not very decisive when going through the menus, you might notice that the playback still stops after about 5 seconds. Not sure what's causing it, though. Might be the parsing in the main thread being blocked.
  • MKV chapter support
    No ordered chapters but just plain old single-file chapter markers, conveniently selectable from a menu.
  • Fullscreen device selection
    You can now select the fullscreen device from a menu, just like in VLC but better. There's an option to select the same screen the player window is on, the selection is automatically updated when the monitor configuration changes and you'll always see which monitor is implicitly or explicitly selected.
    You could, for example, chose to go the the second monitor by default in the preferences. If there's no extra monitor attached, fullscreen would go to the first monitor, but as soon as a second screen gets attached, it will be automatically selected for fullscreen (only works smoothly with integrated video, though).
  • Updated subtitle options
    Subtitle options are now always available since fontconfig will always select a font for you. The size option has been changed to allow arbitrary input and applies to ass and other subtitles as well. There's now also an option to select the default sub color and transparency.
  • No more "preferences changed" nag screens
    Since restarting playback works pretty well, the preferences window now checks if the current movie is seekable and applies the changes without asking if so. There's now also an apply button to keep the window open for further changes.

@GreenyOSX
You could also try following command line option. It'll probably degrade quality visibly, though:
Code:
-lavdopts skiploopfilter=all
(only works for h.264 video)

@Discerptor
Your two problems should be fixed now. ^^
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Old 2008-08-23, 10:34   Link #18
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
Congratulations, anime_layer, I was reading random blogs around and noticed that one of them had a news regarding MPlayer Extended (r6), here's the link (in spanish, tho).

http://www.applesfera.com/2008/08/23...layer-para-mac

More or less at the end they say that the player is very promising and that they hope it gets at the same pace as VLC as in stability and speed, but that it's very good and that it doesn't hurt having it installed in the computer.
Ryoujin is offline   Reply With Quote
Old 2008-08-27, 19:24   Link #19
Pandar
Member
 
 
Join Date: Jan 2008
Great mplayer but I have a minor problem with it. Whenever I open a video file with mplayer it'll open a new window on the first time but when I exit the window and try to open a new video file with mplayer only the audio plays but a new window does not show up. Anyway to fix this? I know on your site it says not to minimize window when changing videos, just wanted to know if there was a way to around this since i find myself often closing the window before opening up a new video file. Thanks!

Last edited by Pandar; 2008-08-27 at 19:46.
Pandar is offline   Reply With Quote
Old 2008-08-28, 04:22   Link #20
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
@Pandar
I couldn't reproduce your problem on my machine. Which video output do you have selected and what exactly are you doing?
Also check if there's anything being reported in the system.log as well as the MPlayer.log.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Reply

Tags
wiki candidate

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.