AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Reply
 
Thread Tools
Old 2008-11-05, 04:14   Link #1
Isariru
Arg, Inspire me
 
 
Join Date: Nov 2007
Location: USA
Age: 25
Default subtitle track for multiple tracks

Hey guys, here is my issue,

I'm watching an anime series with CCCP (Haali+Media player classic) and there are two options for subtitles as shown here:

http://i139.photobucket.com/albums/q...ddias/Subs.jpg

But in the options menu I don't know what to put for priorities to get the second subtitle track to play by default:

[http://i139.photobucket.com/albums/q...dias/Subs2.jpg

Anyways this is my problem: I googled everything I possibly knew, maybe I'm not using the correct search terms, but I have no idea how to get the subtitle track to use the second english subtitle track by default, it always uses the first one, its driving me insane. It doesn't really trouble me too much to click that subtitle track every episode, but I can't rest until I figure this out.. lol.
__________________
Sig removed by Mod (xris) because at 120,244 bytes it exceeds the limits as requested in the forum rules.
Isariru is offline   Reply With Quote
Old 2008-11-05, 09:05   Link #2
emptyeighty
Senior Member
 
Join Date: Jan 2006
Try it this way.
emptyeighty is offline   Reply With Quote
Old 2008-11-05, 10:19   Link #3
Rahan
Senior Member
 
Join Date: Dec 2005
Location: France
It's not possible.
As stated in Emptyeighty's link :

Quote:
NOTE: Some encodes have two or more tracks with the same language code. Sometimes common in english files is to have two English subtitle tracks: one for English audio and one for Japanese audio - usually the one intended for use with the English audio only has translations of onscreen titles and signs, also sometimes one set of subs is style while the other is not. You will only be able to prioritize the first English sub track listed in this example, and not the second. In these cases you will have to manually choose the secondary subtitle track yourself. You could also remux the files yourself to fix the problem permanently.
Rahan is offline   Reply With Quote
Old 2008-11-05, 11:35   Link #4
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 27
Correct. Haali's splitter only supports autoselection of tracks based on track language tags, not track numbers.

If you want to solve this problem either use a player that can do track numbers (mplayer -sid X) or remux the file with mkvmerge and change the default track flag.
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:37.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
We use Silk.