AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2008-11-15, 04:30   Link #81
LordMelkor
Junior Member
 
Join Date: Jul 2006
Ok... I was messing with it for a while, and I found the problem. It's partially my fault for not testing things on default settings. I had had "Head Related Transfer Function (virtual surround for headphones)" (hrtf) enabled, with that enabled, none of the AVIs I tried worked.

I did some googleing and found that apparantly hrtf only works for 48 kHz audio. According to http://www.mplayerhq.hu/DOCS/HTML/en/advaudio.html if the audio source is something other than 48 kHz it needs to be resampled.

I managed to dig up an avi file that had 48 kHz audio, and it played fine. Of course all AVIs played fine if I had hrtf disabled.

So basically some condition needs to be written to take care of that. Maybe enabling that setting could always resamples the audio even if the source is already 48 kHz (easiest thing I can think of).

With that problem to be taken care of, another unrelated issue remains, where when using core video, it is possible to enter full screen only once per session.
LordMelkor is offline   Reply With Quote
Old 2008-11-15, 08:57   Link #82
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
For some reason I've noticed that any format (either KMV or AVI, low or high quality) starts lagging after watching several files, this happens in two computers I got (iMac 2.16 GHz with 1GB of RAM and a MacBook Pro with 2 GB of RAM).

It's ok at the start, but after watching several episodes, lets say 5, sometimes they randomly lag. At first I thought it was my computer but it shouldn't be happening in the other computer (it has better specs than mine), plus, it also happens with low quality AVI files. This lag doesn't happen with QuickTime+Perian nor VLC, maybe it's some sort of memory leak?
Ryoujin is offline   Reply With Quote
Old 2008-11-15, 10:15   Link #83
sk3
Member
 
Join Date: Sep 2007
Age: 28
Quote:
Originally Posted by Ryoujin View Post
For some reason I've noticed that any format (either KMV or AVI, low or high quality) starts lagging after watching several files, this happens in two computers I got (iMac 2.16 GHz with 1GB of RAM and a MacBook Pro with 2 GB of RAM).

It's ok at the start, but after watching several episodes, lets say 5, sometimes they randomly lag. At first I thought it was my computer but it shouldn't be happening in the other computer (it has better specs than mine), plus, it also happens with low quality AVI files. This lag doesn't happen with QuickTime+Perian nor VLC, maybe it's some sort of memory leak?
Do you notice a slow shutdown of Mplayer OS X after watching many files? Your problems looks like it's the same that's happening to me. Usually after watching too many files when i try to close Mplayer OS X the entire OS lags and locks up for a bit. sometimes i have to force quit to shutdown my laptop.
sk3 is offline   Reply With Quote
Old 2008-11-15, 12:20   Link #84
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
Quote:
Originally Posted by sk3 View Post
Do you notice a slow shutdown of Mplayer OS X after watching many files? Your problems looks like it's the same that's happening to me. Usually after watching too many files when i try to close Mplayer OS X the entire OS lags and locks up for a bit. sometimes i have to force quit to shutdown my laptop.
Hmmm... not really, the rest of the computer keeps working fine. I do see a ton of stuff going on in the Console, tho, I'll try to post later some examples.

The strange thing is that there aren't many programs opened at that time, and nothing else that could be sucking the memory (it's usually Safari and Mplayer that are open).

Edit: This is what I usually get:

Code:
11/15/08 6:32:05 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:32:06 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:36:12 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:36:13 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:36:41 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:36:42 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:38:18 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:38:19 PM [0x0-0x23023].hu.mplayerhq.mplayerosx.extended[254] Failed to get value of property 'sub_file'. 
11/15/08 6:38:23 PM MPlayer OSX Extended[266] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary. 
11/15/08 6:38:24 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:38:28 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:38:29 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:43:49 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:43:50 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]            ************************************************ 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]            **** Your system is too SLOW to play this!  **** 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]            ************************************************ 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Possible reasons, problems, workarounds: 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] - Most common: broken/buggy _audio_ driver 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Try -ao sdl or use the OSS emulation of ALSA. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Experiment with different values for -autosync, 30 is a good start. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] - Slow video output 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Try a different -vo driver (-vo help for a list) or try -framedrop! 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] - Slow CPU 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts, 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]     e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] - Broken file 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Try various combinations of -nobps -ni -forceidx -mc 0. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] - Slow media (NFS/SMB mounts, DVD, VCD etc) 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Try -cache 8192. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] - Are you using -cache to play a non-interleaved AVI file? 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266]   - Try -nocache. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Read DOCS/HTML/en/video.html for tuning/speedup tips. 
11/15/08 6:44:07 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] If none of this helps you, read DOCS/HTML/en/bugreports.html. 
11/15/08 6:45:10 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:45:11 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:45:39 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:45:41 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'. 
11/15/08 6:52:43 PM [0x0-0x28028].hu.mplayerhq.mplayerosx.extended[266] Failed to get value of property 'sub_file'.
I do know that the slow message shows up, I use an iMac 2.16 GHz Core 2 Duo with 1 GB of RAM, and these are the settings:



I'm thinking about trying this, would it help?

Code:
lavdopts="threads=2" # this isn't too useful for some codecs where support
            # hasn't been put in, but if you have more than one usable
            # processor core in your computer you should try this to squeeze the most you can.
lavdopts="fast" # got a huge MPEG2 HD stream going that your poor machine
            # just can't handle?  Enable this, it cuts a few corners.
lavdopts="lowres=1" # decode at a smaller resolution; you get more errors, though
lavdopts="skiploopfilter=all" # drops the loop filter; speeds decoding up, loses some quality
framedrop=yes # drops frames (any filters you use won't waste processing speed)
hardframedrop=yes # drops frames and doesn't bother decoding them, even; causes distorted images!
Keep in mind that this happens with either HD MKV files or even low quality AVI files.

Last edited by Ryoujin; 2008-11-15 at 18:58.
Ryoujin is offline   Reply With Quote
Old 2008-11-16, 18:20   Link #85
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Quote:
Originally Posted by Ryoujin View Post
For some reason I've noticed that any format (either KMV or AVI, low or high quality) starts lagging after watching several files, this happens in two computers I got (iMac 2.16 GHz with 1GB of RAM and a MacBook Pro with 2 GB of RAM).

It's ok at the start, but after watching several episodes, lets say 5, sometimes they randomly lag. At first I thought it was my computer but it shouldn't be happening in the other computer (it has better specs than mine), plus, it also happens with low quality AVI files. This lag doesn't happen with QuickTime+Perian nor VLC, maybe it's some sort of memory leak?
Open your Acitivity Monitor and look at your "inactive RAM" as you play those files. It steadily builds to a point where there is no free RAM eft, and instead of being forked over to be used like it should at that point, it forces the system to start making page-outs like crazy, resulting in bad performance. I first noticed the problem when I ran MPlayer on Leopard, and it happens with both GUI and commandline versions. No one on the mailing list seems to acknowledge the problem as existent until I bring it to attention, and the best response I've gotten so far has been a claim that it's "okay" because some other random program does the same thing (though I can kind of see why no one wants to deal with the problem; Mplayer was made as a viable option on Linux originally, and OS X is the only platform that has to deal with "inactive RAM" vs. "free RAM" nonsense in the first place... just means that MPlayer is a bit crippled on OS X Leopard for things like marathoning several anime episodes, etc.).

Until someone commits an Mplayer patch (or I have enough free time to actually look at why MPlayer but neither VLC nor Quicktime+Perian do this despite using the same codecs...), I've employed the solution of once every so often running a shell script that dumps the bulk of inactive RAM and produces an output file by abusing the "du" command. It's a pretty simple script that's equivalent to typing just one line in Terminal:

Code:
#!/bin/bash
du a -> du -sh
Bear in mind that if you create a script that does this, you should make sure you give it the appropriate permissions to execute on double click, etc. You'd accomplish in Terminal this with:
Code:
chmod +x shellscript.sh
where shellscript.sh is whatever you named it.

Last edited by Discerptor; 2008-11-16 at 18:35.
Discerptor is offline   Reply With Quote
Old 2008-11-16, 22:02   Link #86
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
I forgot to mention that sometimes the cursor dissapears, only when you have Mplayer at the top of the application stack. It gets fixed after closing and re-opening the application, tho. This happens randomly (rare-random).

And more random errors in the Console, for reference:

Code:
11/16/08 9:09:12 PM MPlayer OSX Extended[485] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary. 
11/16/08 9:09:13 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] FAAD: compressed input bitrate missing, assuming 128kbit/s! 
11/16/08 9:09:13 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:09:41 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:09:42 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:10:49 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:10:50 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:23:49 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:23:50 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:26:42 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:26:43 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:26:47 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:28:20 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:28:21 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:33:19 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] FAAD: compressed input bitrate missing, assuming 128kbit/s! 
11/16/08 9:33:19 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:42:55 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:42:56 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:43:31 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:43:32 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:43:42 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:43:43 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:44:40 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:44:41 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:44:42 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:56:15 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:56:16 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:56:45 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:56:46 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:56:50 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 9:56:51 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 10:01:06 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] FAAD: compressed input bitrate missing, assuming 128kbit/s! 
11/16/08 10:01:07 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] [mkv] Warning: No BlockDuration for subtitle track found. 
11/16/08 10:01:07 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 10:01:20 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'. 
11/16/08 10:01:21 PM [0x0-0x57057].hu.mplayerhq.mplayerosx.extended[485] Failed to get value of property 'sub_file'.
Ryoujin is offline   Reply With Quote
Old 2008-11-21, 19:08   Link #87
sk3
Member
 
Join Date: Sep 2007
Age: 28
Ok i finally found out the problem i'm having with mplayer, and i'm pretty sure everyone has it but no one notices it.

After watching a movie and then closing the file, i got activity monitor open and i noticed that mplayer os x was using about 350MB of RAM. now i suppose that this is a memory leak present in mplayer and that makes mplayer OS X eat so much memory. I also noticed that when i try to close it, it takes a long while to close, but at some point, activity monitor refreshes and shows a usage memory of 96MB of RAM and then the program closes.

I've experienced this every time i watch something on mplayer os x for a while.

I'm going to try compiling mplayer on mac os x and see if the latest SVN revision works. I hope so

EDIT1: i've finished compiling mplayer and posted a link for download if anyone want to try it out.

http://localhostr.com/files/23ed95/mplayer.zip

So far so good but i didn't test it with the right time. tonight i'll check it out and see if makes a difference.

Versions:

MPlayer dev-SVN-r27807-4.0.1 - this is the revision of the mplayer included in the latest rev7 of Mplayer OS X Extended

MPlayer dev-SVN-r27978-4.0.1 - this is the revision of my first try at compiling mplayer

The compilation was made following the steps anime_layer wrote on the compiling thread of mplayer 2008.

If someone decides to test it, please report the problems

EDIT2: Ok, so i tested this build and looks fine, at least with several MKV's. I noticed also a small decrease in "breaks" that mplayer always done but that might be because of the file sizes.

Anyway, the problem persists, but at least i got a different result this time. At least this time Mplayer OS X consumed for the same time, only 290MB. This might be possible because of more recent SVN revision, but my problem still exists, and now what's left to do is to search for some kind of "memory leak" on Mplayer OS X GUI.

i don't know if this is true but as you can see in the following screenshot, it's the result of mplayer os x after running for about 5 hours continuously:



About other stuff, i don't really know but it might be possible that the recent version uses less CPU for decoding. i say this because i heard less noise from fans but might be coincidence.

Anyway, if somebody has the courage to test this build, comment about your experience

Also, Ryoujin it would be great if you tested this build and check if your lag problems are gone.

Last edited by sk3; 2008-11-22 at 01:03.
sk3 is offline   Reply With Quote
Old 2008-11-22, 16:47   Link #88
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
Allow me to make a short offtopic question:

Quote:
OS X is the only platform that has to deal with "inactive RAM" vs. "free RAM"
What the hell is "inactive RAM"? Is it some sort of OS X-esque version of the good ol' cache?
__________________


Place them in a box until a quieter time | Lights down, you up and die.
WanderingKnight is offline   Reply With Quote
Old 2008-11-23, 03:09   Link #89
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Quote:
Originally Posted by WanderingKnight View Post
Allow me to make a short offtopic question:



What the hell is "inactive RAM"? Is it some sort of OS X-esque version of the good ol' cache?
Inactive RAM is where stuff that would go in the cache goes unless another program needs the physical memory, at which point it's put in cache instead. Unfortunately, it seems mplayer has a pretty bad leak here and does it in such a manner that other apps can't take the physical memory space being used as "inactive RAM." This webpage might help:

http://support.apple.com/kb/HT1342
Discerptor is offline   Reply With Quote
Old 2008-11-26, 17:43   Link #90
Epyon9283
Geek
 
 
Join Date: Dec 2005
Location: New Jersey
Age: 31
Send a message via ICQ to Epyon9283 Send a message via AIM to Epyon9283
Anyone else notice that windowserver starts eating RAM when mplayer is open. I had it open for not even two hours and windowserver was up to 400MB of RAM. As soon as I closed mplayer it went back down to 68MB.
Epyon9283 is offline   Reply With Quote
Old 2008-12-09, 17:11   Link #91
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
Well, I can imagine that memory leaks slipped into the code. I've only begun working with Objective-C on MPlayerOSX and I first have to learn how Cocoa's memory management works. I've learned a lot in that regard and plan to scan the code for memory leaks.

I've been working on new features, notably:
  • Fullscreen controls
  • Automatic updates with Sparkle
  • Font and font style selection with Fontconfig
  • Automatic detecting of subtitle encoding for supported languages
  • Improved and expanded font, subtitles and osd options
  • Options for AC3 and DTS pass-through
  • Internal video output support for multiple gui instances
  • Better Fontconfig cache warning
  • Other small fixes

If anyone wants to try these features out, here's a prerelease version of rev8:
http://mplayerosx.sttz.ch/downloads/...rev8-test1.dmg

I haven't much tested these new features so expect some lingering bugs. I plan to push a second prerelease through Sparkle sometime later.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Old 2008-12-09, 17:32   Link #92
sk3
Member
 
Join Date: Sep 2007
Age: 28
Great to see news anime_layer

I would like to help you but i think my "brain" doesn't go too far with programming.

Quote:
Options for AC3 and DTS pass-through
is this something like, muxing options on CCCP audio controls? if it is, it's very much appreciated

I would like to test this new release but im currently without my laptop :/ died the day after i posted my version of mplayer.
sk3 is offline   Reply With Quote
Old 2008-12-11, 12:27   Link #93
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Quote:
Originally Posted by anime_layer View Post
Well, I can imagine that memory leaks slipped into the code. I've only begun working with Objective-C on MPlayerOSX and I first have to learn how Cocoa's memory management works. I've learned a lot in that regard and plan to scan the code for memory leaks.

I've been working on new features, notably:
  • Fullscreen controls
  • Automatic updates with Sparkle
  • Font and font style selection with Fontconfig
  • Automatic detecting of subtitle encoding for supported languages
  • Improved and expanded font, subtitles and osd options
  • Options for AC3 and DTS pass-through
  • Internal video output support for multiple gui instances
  • Better Fontconfig cache warning
  • Other small fixes

If anyone wants to try these features out, here's a prerelease version of rev8:
http://mplayerosx.sttz.ch/downloads/...rev8-test1.dmg

I haven't much tested these new features so expect some lingering bugs. I plan to push a second prerelease through Sparkle sometime later.
Which SVN revision of mplayer does this version of MPlayer OSX Extended use? Also, my situation is similar to that os sk3, but I should be able to test again by a week from today.
Discerptor is offline   Reply With Quote
Old 2008-12-11, 12:33   Link #94
sk3
Member
 
Join Date: Sep 2007
Age: 28
Quote:
Originally Posted by Discerptor View Post
Which SVN revision of mplayer does this version of MPlayer OSX Extended use? Also, my situation is similar to that os sk3, but I should be able to test again by a week from today.
You mean you also noticed the slowdowns and memory consumption? If yes, good thing im not the only one
sk3 is offline   Reply With Quote
Old 2008-12-11, 16:12   Link #95
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
Quote:
Originally Posted by Discerptor View Post
Which SVN revision of mplayer does this version of MPlayer OSX Extended use?
It uses r28117 from Dezember 9th. I usually bundle a compile pretty close to the release day.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Old 2008-12-12, 00:52   Link #96
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
Quote:
Originally Posted by sk3 View Post
You mean you also noticed the slowdowns and memory consumption? If yes, good thing im not the only one
Actually, I meant my computer is out of commission. According to Apple, I should be getting the repaired unit back by 10:30 tomorrow morning. As for slowdowns/memory leaks, I've only noticed the inactive RAM memory leak that is a problem with mplayer itself and thus not something anime_layer can fix by adjusting MPlayer OSX Extended anyway.

Quote:
Originally Posted by anime_layer View Post
It uses r28117 from Dezember 9th. I usually bundle a compile pretty close to the release day.
Cool. I'll test out the app tomorrow.
Discerptor is offline   Reply With Quote
Old 2008-12-12, 10:45   Link #97
sk3
Member
 
Join Date: Sep 2007
Age: 28
Oh looks like mine wasn't the only one to die either i got the "black screen of death" problem. Damn 8600MGT

And by the way, i think i'm going to get the newer models (2 weeks have passed since warranty, so if my problem isn't resolved within the next 2 weeks i'll demand my money back )

With a bit of luck i might get the newer models and it would be cool to test out the new h264 acceleration.

Also, i read something in a linux site that mplayer already has some sort of the h264 acceleration for nvidia cards (some patches are needed) but AFAIK that it won't work in OS X (different API's i guess) When Snow Leopard is here something could be done about that. (might help with the new OpenCL thing)

When i get my laptop back i'll give news and test the newest version of mplayer os x extended
sk3 is offline   Reply With Quote
Old 2008-12-12, 21:55   Link #98
Discerptor
ANIUE!111
 
 
Join Date: Oct 2006
This new revision looks promising. I like the full-screen controls, and the loader for the updating fontconfig will probably put a lot of worried souls to rest. I'm also impressed with all the new text preferences, though I haven't really had a chance to try them out with anything yet. Of course, I still have that inactive RAM problem, but as I said, that's a problem with mplayer itself, so there's nothing we can do about it. I'll let you know if I run into anything hairy.
Discerptor is offline   Reply With Quote
Old 2008-12-12, 23:53   Link #99
sk3
Member
 
Join Date: Sep 2007
Age: 28
Quote:
Originally Posted by Discerptor View Post
This new revision looks promising. I like the full-screen controls, and the loader for the updating fontconfig will probably put a lot of worried souls to rest. I'm also impressed with all the new text preferences, though I haven't really had a chance to try them out with anything yet. Of course, I still have that inactive RAM problem, but as I said, that's a problem with mplayer itself, so there's nothing we can do about it. I'll let you know if I run into anything hairy.
Could you post some screenshots about those new features you mentioned?
sk3 is offline   Reply With Quote
Old 2008-12-14, 16:04   Link #100
Idgit
Junior Member
 
Join Date: Jul 2007
Quote:
Originally Posted by sk3 View Post
Oh looks like mine wasn't the only one to die either i got the "black screen of death" problem. Damn 8600MGT
Ya the same thing happened to mine a month ago, damn defective nvidia cards.

I just updated to rev 2 of the pre-release and all seems to be going well, I really like the fullscreen control. Thanks for all the work you're putting into it.
Idgit is offline   Reply With Quote
Reply

Tags
wiki candidate

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.