AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2009-05-21, 15:30   Link #221
Proudleaf
Senior Member
 
 
Join Date: Jul 2008
Location: USA
Age: 24
Quote:
Originally Posted by sk3 View Post
Well i can assure you, since i have a macbook pro, that these things run hot but not as much as yours. *EDIT: by the fact that i don't run the fans and default speed.

My advice is to download smc fan control 2, and configure the fans from your mac. mine's are set at 2000rpm during battery and 4000rpm during power cable, and that give's me about 30-45º temperature watching 720p for a long time and usually no more than 60º during 1080p playback. you can also create your own profiles and speed up the fans as you need. I found out that i cannot run my laptop without this program
I second downloading SMC Fan Control 2. One of the best apps for any macbook user, hands down.
Proudleaf is offline   Reply With Quote
Old 2009-05-21, 16:00   Link #222
ichobi
Senior Member
 
 
Join Date: Dec 2005
I tried that and it didn't work. The machine still lag out and peaked at 85 degree. That's super hot and rendered my machine useless. So this evening I eventually dissected my Macbook and see what happens....





Very dirty and ugly isnt' it?

But the accumulated dust is not the culprit.


THis is the culprit




The Chinese workers have no idea how to properly applied thermal paste. It's too much and too thick and now all dried out so the heat transfer wasn't efficient and resulted in my machine lock down.

I ran out to the local electronic store and got my self a Silver thermal paste, then applied thinly and evenly.



The result was staggering, now my macbook peaked at 70 degree Celsius!!! Idle at 40 degree only! That's massive 35-40 degree drop in temperature! And now I can watch any 1080p files with out a hiccup!

Thanks for your help though, I know it has to come to dissecting sooner or later because I always have this problem ever since I purchased. Just need to wait until the warranty expires!
ichobi is offline   Reply With Quote
Old 2009-05-21, 17:01   Link #223
Proudleaf
Senior Member
 
 
Join Date: Jul 2008
Location: USA
Age: 24
Quote:
Originally Posted by ichobi View Post
The result was staggering, now my macbook peaked at 70 degree Celsius!!! Idle at 40 degree only! That's massive 35-40 degree drop in temperature! And now I can watch any 1080p files with out a hiccup!

Thanks for your help though, I know it has to come to dissecting sooner or later because I always have this problem ever since I purchased. Just need to wait until the warranty expires!
Well I guess that's one way to solve the problem.

Congrats on your results though.
Proudleaf is offline   Reply With Quote
Old 2009-05-21, 18:49   Link #224
sk3
Member
 
Join Date: Sep 2007
Age: 27
Quote:
Originally Posted by ichobi View Post
I tried that and it didn't work. The machine still lag out and peaked at 85 degree. That's super hot and rendered my machine useless. So this evening I eventually dissected my Macbook and see what happens....



Very dirty and ugly isnt' it?

But the accumulated dust is not the culprit.


THis is the culprit


The Chinese workers have no idea how to properly applied thermal paste. It's too much and too thick and now all dried out so the heat transfer wasn't efficient and resulted in my machine lock down.

I ran out to the local electronic store and got my self a Silver thermal paste, then applied thinly and evenly.


The result was staggering, now my macbook peaked at 70 degree Celsius!!! Idle at 40 degree only! That's massive 35-40 degree drop in temperature! And now I can watch any 1080p files with out a hiccup!

Thanks for your help though, I know it has to come to dissecting sooner or later because I always have this problem ever since I purchased. Just need to wait until the warranty expires!
I want to open mine to check the same since sometimes when running on full it goes around 85º, but if i put my fans to kick in before (i usually put them at 5200rpm for gaming) it usually stays between 75-82º.

My warranty only ends in august so i think i'll wait until it ends, then i can change my hard disk and re-apply thermal paste

Did you open by yourself or follow ifixit guides?
sk3 is offline   Reply With Quote
Old 2009-05-21, 20:02   Link #225
ichobi
Senior Member
 
 
Join Date: Dec 2005
Yeah I followed Ifixit guide. It's very clear and to the point. Be warned though, Macbook internals are very sensitive. After I reassemble I couldn't turn it on because some screw were loose and the internals could shake and cause system failure. I have to reopen the chassis and make sure everything is properly fixed and screwed. The 2nd time I don't need the guide because I can remember all the screw positions. You will have to deal with approx 20 screws so mark their position before you proceed.

Other than that, the process is simple if you are comfortable with pc hardware. When you apply thermal paste, make sure it's thin and evenly but cover the CPU die completely. Also polish the heatsink will help with heat transfer too

I also remove a lot of dust with cottonbutt. Need to be delicate or you might risk break something inside

If you are unsure how to remove some plugs e.g. fan plugs and thermometer (was very tricky) make sure you check out instruction videos on youtube like this one.

http://www.youtube.com/watch?v=REglcP2xw-w

Very helpful! hopes that helps
ichobi is offline   Reply With Quote
Old 2009-05-21, 20:31   Link #226
sk3
Member
 
Join Date: Sep 2007
Age: 27
Thanks for the info, i am very confortable with playing with computer hardware (i worked on a shop ) but this machine cost me too much to "play with it"

I'll do it in a few months, now waiting for countdown

Thanks again
sk3 is offline   Reply With Quote
Old 2009-05-22, 22:25   Link #227
sk3
Member
 
Join Date: Sep 2007
Age: 27
Hm, i'm have came across this anoying bug in Mplayer OSX Extended. I don't know what caused it, but i think after 10.5.7 update, the preferences panel from Mplayer OS X Extended doesn't work anymore.

I mean, even if i change anything, the Apply and OK buttons doesn't do anything, only Cancel button works. i don't remember if before the update it was doing this but i don't think so.

I've searched the Trac and looks like there are similar problems like mine, so looks like it's not only me

Waiting anxiously for rev11
sk3 is offline   Reply With Quote
Old 2009-05-26, 23:19   Link #228
Proudleaf
Senior Member
 
 
Join Date: Jul 2008
Location: USA
Age: 24
Quote:
Originally Posted by sk3 View Post
Hm, i'm have came across this anoying bug in Mplayer OSX Extended. I don't know what caused it, but i think after 10.5.7 update, the preferences panel from Mplayer OS X Extended doesn't work anymore.

I mean, even if i change anything, the Apply and OK buttons doesn't do anything, only Cancel button works. i don't remember if before the update it was doing this but i don't think so.

I've searched the Trac and looks like there are similar problems like mine, so looks like it's not only me

Waiting anxiously for rev11
That is strange. I'm still operating on Tiger, so I'm a bit behind the times I guess.

I'm curious as to what Rev11 will feature though, aside from bug fixing.
Proudleaf is offline   Reply With Quote
Old 2009-05-27, 12:13   Link #229
chikorita157
ひきこもりアイドル
*IT Support
 
 
Join Date: Feb 2009
Location: New Jersey, United States
Age: 24
Send a message via Skype™ to chikorita157
Quote:
Originally Posted by sk3 View Post
Hm, i'm have came across this anoying bug in Mplayer OSX Extended. I don't know what caused it, but i think after 10.5.7 update, the preferences panel from Mplayer OS X Extended doesn't work anymore.

I mean, even if i change anything, the Apply and OK buttons doesn't do anything, only Cancel button works. i don't remember if before the update it was doing this but i don't think so.

I've searched the Trac and looks like there are similar problems like mine, so looks like it's not only me

Waiting anxiously for rev11
This is very strange because I have tried to set preferences under my Unibody Macbook Pro which I applied the 10.5.7..

I suggest using removing the preference files by dragging MPlayer OS X Extended using AppCleaner and try again. If it doesn't help, try downloading the 10.5.7 Combo Update and install it.
__________________
chikorita157 is offline   Reply With Quote
Old 2009-05-27, 12:54   Link #230
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
Quote:
Originally Posted by sk3 View Post
I mean, even if i change anything, the Apply and OK buttons doesn't do anything, only Cancel button works. i don't remember if before the update it was doing this but i don't think so.
Please send me your preferenes file (in ~/Library/Preferences/hu.mplayerhq.mplayerosx.extended.plist) or post what message you get printed to the system.log when you click OK or Apply.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Old 2009-05-27, 17:37   Link #231
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
rev11-test1 is out!
  • New icon by mar2o
  • Enable volume changing and seeking with the scroll wheel
  • Allow player window to be dragged by clicking on the video
  • Option to black out other screens while in fullscreen
  • Don't hide player window to allow using it on a second screen
  • Check that fullscreen controls are never placed off-screen
  • Don't hide menu bar except when going fullscreen on main screen
  • On-top now doesn't place the window above menus
  • Additional option for on-top while playing only
  • Update cache slider ranger to 256MB and allow higher values to be entered
  • Fixed a crash when going to fullscreen
  • Fix a problem with preferences window not closing
  • Fix a memory leak in the video output (patch by mpx-trax AT the-color-black.net)
  • Fix MPlayer being marked as unresponsive and spindump on Leopard eating CPU
  • New MPlayer and MPlayer-MT build from 27. May 2009 (r29324)

Edit: Oh, and could you check if your mplayer process is still marked as inactive in Activity Monitor? Thanks!
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.

Last edited by anime_layer; 2009-05-28 at 01:03.
anime_layer is offline   Reply With Quote
Old 2009-05-28, 07:10   Link #232
Cpuroast
Member
 
 
Join Date: Mar 2009
Quote:
Originally Posted by anime_layer View Post
rev11-test1 is out!
  • New icon by mar2o
  • Enable volume changing and seeking with the scroll wheel
  • Allow player window to be dragged by clicking on the video
  • Option to black out other screens while in fullscreen
  • Don't hide player window to allow using it on a second screen
  • Check that fullscreen controls are never placed off-screen
  • Don't hide menu bar except when going fullscreen on main screen
  • On-top now doesn't place the window above menus
  • Additional option for on-top while playing only
  • Update cache slider ranger to 256MB and allow higher values to be entered
  • Fixed a crash when going to fullscreen
  • Fix a problem with preferences window not closing
  • Fix a memory leak in the video output (patch by mpx-trax AT the-color-black.net)
  • Fix MPlayer being marked as unresponsive and spindump on Leopard eating CPU
  • New MPlayer and MPlayer-MT build from 27. May 2009 (r29324)

Edit: Oh, and could you check if your mplayer process is still marked as inactive in Activity Monitor? Thanks!
MPlayer rev 11 test 1 is still being marked as unresponsive and spindump still starts eating ~12% cpu on a core 2 2ghz.

So the problem is still there.
Cpuroast is offline   Reply With Quote
Old 2009-05-28, 13:28   Link #233
exs120
Uruchai Uruchai Uruchai
 
Join Date: Jun 2006
I found that if you have Mplayer start in fullscreen and then exit full screen (normal size), the aspect ratio gets messed up and parts of the video get cut off. It seems like the player still thinks it is in full screen when it is not.
exs120 is offline   Reply With Quote
Old 2009-05-28, 19:37   Link #234
chikorita157
ひきこもりアイドル
*IT Support
 
 
Join Date: Feb 2009
Location: New Jersey, United States
Age: 24
Send a message via Skype™ to chikorita157
It seems that mplayer rev 11 does use alot of CPU.

__________________
chikorita157 is offline   Reply With Quote
Old 2009-05-28, 21:59   Link #235
Epyon9283
Geek
 
 
Join Date: Dec 2005
Location: New Jersey
Age: 30
Send a message via ICQ to Epyon9283 Send a message via AIM to Epyon9283
Quote:
Originally Posted by anime_layer View Post
Edit: Oh, and could you check if your mplayer process is still marked as inactive in Activity Monitor? Thanks!
Not getting marked as not responding here.
Epyon9283 is offline   Reply With Quote
Old 2009-05-29, 00:33   Link #236
Proudleaf
Senior Member
 
 
Join Date: Jul 2008
Location: USA
Age: 24
Quote:
Originally Posted by anime_layer View Post
rev11-test1 is out!
  • New icon by mar2o
  • Enable volume changing and seeking with the scroll wheel
  • Allow player window to be dragged by clicking on the video
  • Option to black out other screens while in fullscreen
  • Don't hide player window to allow using it on a second screen
  • Check that fullscreen controls are never placed off-screen
  • Don't hide menu bar except when going fullscreen on main screen
  • On-top now doesn't place the window above menus
  • Additional option for on-top while playing only
  • Update cache slider ranger to 256MB and allow higher values to be entered
  • Fixed a crash when going to fullscreen
  • Fix a problem with preferences window not closing
  • Fix a memory leak in the video output (patch by mpx-trax AT the-color-black.net)
  • Fix MPlayer being marked as unresponsive and spindump on Leopard eating CPU
  • New MPlayer and MPlayer-MT build from 27. May 2009 (r29324)

Edit: Oh, and could you check if your mplayer process is still marked as inactive in Activity Monitor? Thanks!
Interesting, does the new Mplayer-MT build not have the problem with packed b-frames anymore? Because after playing a few videos of high-def animated material, the playback does seem smoother with FFmpeg-MT enabled.

I love the new icon too.
Proudleaf is offline   Reply With Quote
Old 2009-05-30, 20:04   Link #237
Mr VacBob
yotsuba channel
 
Join Date: Oct 2004
Location: GA
Age: 26
Send a message via AIM to Mr VacBob
I turned off multithreading for mpeg4 a while ago. I think I know what the problem is now, but it already decodes so fast you'd hardly notice it only using one core.
Mr VacBob is offline   Reply With Quote
Old 2009-05-31, 11:53   Link #238
chikorita157
ひきこもりアイドル
*IT Support
 
 
Join Date: Feb 2009
Location: New Jersey, United States
Age: 24
Send a message via Skype™ to chikorita157
I tested the newest build on my sisters Macbook Pro (2.66 GHz Model)

MT off:

It seems to use alot more CPU with MT off and mplayer window reports "Not Responding"

MT on:

With MT, it uses alot less CPU and not reports the mplayer window "not responding", but marks it after several minutes of playing video.
__________________
chikorita157 is offline   Reply With Quote
Old 2009-05-31, 13:28   Link #239
Proudleaf
Senior Member
 
 
Join Date: Jul 2008
Location: USA
Age: 24
Quote:
Originally Posted by Mr VacBob View Post
I turned off multithreading for mpeg4 a while ago. I think I know what the problem is now, but it already decodes so fast you'd hardly notice it only using one core.
I'm not sure what you mean, but multithreading is EXTREMELY helpful for 1080p playback on my computer, so I prefer to use the option. However, if I'm not mistaken, previous MT builds had a problem with decoding b-frames in h264 video, so the option still had some issues.

What I'm wondering is if that problem has since been resolved, because after testing Rev11's MT build, everything that is h264 (not just 1080p playback) seems to perform slightly smoother.
Proudleaf is offline   Reply With Quote
Old 2009-05-31, 13:37   Link #240
Mr VacBob
yotsuba channel
 
Join Date: Oct 2004
Location: GA
Age: 26
Send a message via AIM to Mr VacBob
"Packed b-frames" are divx, not h264. h264 was fixed and optimized too, though.
Mr VacBob is offline   Reply With Quote
Reply

Tags
wiki candidate

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 22:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.