AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2009-10-11, 20:08   Link #1
Sub-zero 4ever
Junior Member
 
 
Join Date: May 2009
Does monitor size affect playing media?

the problem: my pc plays HD slowly. both 720p and 1080p. No problem with 1024576.

Cpu: P4 2800MHz
Ram: 1GB+256MB
OS: WinXP SP3
VGA: tried both: nVidia MX 4000 and nVidia 8600 GT with the latest drivers (I saw no real difference)
Monitor: 14-inch LG studioworks 560N
HD: 10000 RPM
Codecs: tryed K-lite 495f. then tried CoreAVC 1.9.5.0 (tried the latter with deblocking disabled)
players tested: MPC - mplayer2.exe - VLC (MPC: slow. mplayer2: less slow. VLC: dont ask )

edit: slot is AGP 4X

Tested file's info: (MediaInfo)
Spoiler for click to show:



and it looks like the cpu is trying to kill himself in decoding ... trying to jump beyond the limits of 100% specially at the op.

and i thought upgrading my VGA card (to nvidia 8600 gt) can solve the problem a bit, but seems there is no difference at all.

so is the cpu time the cause after all (2800 mhz)? or it is just because my monitor cannot display media at resolutions higher than it can display (since the higher res my monitor can get is 1024*768)? coz my other computer has a monitor with res 1280 * 1024 and very close hardware implementation and it plays 720p smoothly.

i am desperate
any help or advice plz?

Last edited by Sub-zero 4ever; 2009-10-14 at 03:26.
Sub-zero 4ever is offline   Reply With Quote
Old 2009-10-12, 06:18   Link #2
demonix
Senior Member
 
 
Join Date: Jul 2006
Location: Hayes, Middx UK
Age: 35
Send a message via Yahoo to demonix Send a message via Skype™ to demonix
If the CPU in your other computer is more powerful then the one your having problems playing HD videos with then that's the cause of your problems (although I doubt a P4 would be able to handle decoding HD video)
demonix is offline   Reply With Quote
Old 2009-10-12, 12:26   Link #3
gugumomu
the hedgehog
 
 
Join Date: Jan 2007
Location: somewhere over the rainbow
you could try with hardware (graphics-card) instead of software (CPU) decode of H.264 videos.
uninstall k-lite(or any other codecs-pack you have) and Haali Splitter that came with CoreAVC195.
install CCCP. then follow the instructions on how to use CoreAVC with CCCP: How to use CoreAVC instead of FFDShow.
then go to the CoreAVC settings page and enable "Prefer CUDA Acceleration". this wont work on H.264 files with 16Reframes (the CPU will still do the decoding). "[Himatsubushi]_Needless_-_01_[720p][H264]" has 9Reframes so it will work flawless.
still, your P4 2800MHz should play 720p in software-mode without problems nevertheless.
__________________
gugumomu is offline   Reply With Quote
Old 2009-10-12, 13:42   Link #4
chikorita157
ひきこもりアイドル
*IT Support
 
 
Join Date: Feb 2009
Location: New Jersey, United States
Age: 24
Send a message via Skype™ to chikorita157
Since you have a compatible graphics card (nVidia Geforce 8600), you can try the DXVA support which will allow acceleration of H264 video. This tutorial should help you...

The resolution shouldn't really impact the video performance... however... since the CPU does most of the encoding and the CPU shouldn't really be a problem really.
__________________
chikorita157 is offline   Reply With Quote
Old 2009-10-14, 14:59   Link #5
synaesthetic
blinded by blood
*Author
 
 
Join Date: Jun 2009
Location: Oakland, CA
Age: 30
Send a message via AIM to synaesthetic Send a message via Skype™ to synaesthetic
Your processor is your bottleneck.

Since you have an nVidia graphics card, try using CoreAVC (you can get a trial version for free from corecodec.com to see if it works) and enable CUDA hardware decoding for h.264 video. That should fix you up just fine. CoreAVC isn't free though, but it is only $15.
__________________
synaesthetic is offline   Reply With Quote
Old 2009-10-14, 18:44   Link #6
Sub-zero 4ever
Junior Member
 
 
Join Date: May 2009
Thanks friends for giving me these solutions.

I tried all of the above and I didnt get any satisfying results. Best result was with CoreAVC after all. but even ... the CPU looked like burning when decoding.

and it seems that the DVXA is not working properly. Whatever i tried with MPC-HC. and not to mention that the latest CCCP didnt include CoreAVC in its bundle, they simply put FFdshow instead.

i did some research too. looks like the main problem is my motherbourd since the slot is AGP 4X which makes the bottleneck for the VGA card and prevents it from functioning at its real preformance.

also about CUDA, it doesnt seem it supports VGA cards.

and now i believe i did a mistake when i bought this card lol.

but if i'm wrong plz point the wrong points in what i said.
Sub-zero 4ever is offline   Reply With Quote
Old 2009-10-14, 20:22   Link #7
synaesthetic
blinded by blood
*Author
 
 
Join Date: Jun 2009
Location: Oakland, CA
Age: 30
Send a message via AIM to synaesthetic Send a message via Skype™ to synaesthetic
Just by itself CoreAVC will make a difference, because it's faster than libavcodec.

But since you have a GeForce graphics card, make sure you select "Prefer CUDA acceleration" in CoreAVC's control panel. It should then decode h.264 with the graphics card instead of your processor.

At that point, the only thing the processor should be doing is rendering your subtitles. Your CPU usage should be in the 20-25% range.

CoreAVC does not come with CCCP, because it's not free. You can purchase it from corecodec.com for $15.

Edit: The 8x series of GeForce cards should work with CUDA, according to nVidia. Try updating to the newest reference drivers from nvidia.com.

If CUDA or DXVA isn't working, then your graphics card is not being used to decode the video. Your graphics card and the AGP4x bus isn't even entering into the equation unless you enable hardware acceleration through one of the two aforementioned methods.
__________________
synaesthetic is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 21:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.