AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > Anime Related Topics > Fansub Groups

Notices

Reply
 
Thread Tools
Old 2010-12-06, 21:20   Link #1
RelaxRelapse
0.o
 
 
Join Date: Jun 2010
Adding .ass to .mkv

I've been having trouble merging my .ass file with my .mkv file. Everyime I try merging with mkvtoolnix it creates a .mkv with just audio and the subtitles. I'm doing this all on a MacBook if that helps at all..

Thanks,
RR
RelaxRelapse is offline   Reply With Quote
Old 2010-12-07, 04:55   Link #2
DmonHiro
Senior Member
 
 
Join Date: Oct 2006
Location: Romania
Age: 27
Send a message via Yahoo to DmonHiro
Try using an older version of MKVMerge. The newer versions have issues. I'm still using 3.2.0, cause later ones either don't mux the subs right, or compress the header.
DmonHiro is offline   Reply With Quote
Old 2010-12-07, 05:26   Link #3
Desbreko
Senior Member
*Fansubber
 
 
Join Date: Apr 2009
Age: 26
Send a message via AIM to Desbreko
4.2.0 had issues with muxing subs, I think it was. 4.4.0 (the current latest version) seems to work okay if you disable header removal compression on audio and video tracks, but in files muxed with it, avdump doesn't seem to be able to recognize that sub tracks are tagged as English. It sees them as unknown for some reason. So, that might cause issues if you're releasing stuff that's going to get dumped on AniDB.

I've been using 3.4.0 and haven't had any trouble with it.
Desbreko is offline   Reply With Quote
Old 2010-12-07, 10:27   Link #4
sneaker
Senior Member
 
Join Date: Dec 2008
Quote:
Originally Posted by Desbreko View Post
4.2.0 had issues with muxing subs, I think it was. 4.4.0 (the current latest version) seems to work okay if you disable header removal compression on audio and video tracks, but in files muxed with it, avdump doesn't seem to be able to recognize that sub tracks are tagged as English. It sees them as unknown for some reason. So, that might cause issues if you're releasing stuff that's going to get dumped on AniDB.

I've been using 3.4.0 and haven't had any trouble with it.
It doesn't write flags that equal the default value anymore since 4.0.0 and the default "track language" value is English. That's why some programs do not correctly recognize tracks as English anymore.
ASS muxing problems introduced in 4.2.0 have been fixed with 4.3.0.
sneaker is offline   Reply With Quote
Old 2010-12-07, 23:12   Link #5
RelaxRelapse
0.o
 
 
Join Date: Jun 2010
Cool I'll try some of these. Thanks for the help!
RelaxRelapse is offline   Reply With Quote
Old 2010-12-08, 01:53   Link #6
Desbreko
Senior Member
*Fansubber
 
 
Join Date: Apr 2009
Age: 26
Send a message via AIM to Desbreko
Quote:
Originally Posted by sneaker View Post
It doesn't write flags that equal the default value anymore since 4.0.0 and the default "track language" value is English. That's why some programs do not correctly recognize tracks as English anymore.
ASS muxing problems introduced in 4.2.0 have been fixed with 4.3.0.
Well that's dumb. I could see not writing default values when they haven't been specified in the command line, but when I explicitly tell mkvmerge to flag a track as English, I expect it to actually do so.

It looks like you can get around it by using mmg's header editor to add the language flag, but that's a pain.
Desbreko is offline   Reply With Quote
Old 2010-12-13, 07:59   Link #7
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 27
3.4.0 or bust
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 17:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.