AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Tech Support

Notices

Reply
 
Thread Tools
Old 2012-01-17, 20:43   Link #1
Hiroi Sekai
Minna no ojou-sama~♥
*Graphic Designer
 
 
Join Date: Jan 2009
Location: Kelowna, British Columbia
Age: 22
Send a message via Skype™ to Hiroi Sekai
The Old Blinking Subtitles on MKV

Howdy, sorry if this has already been asked, but...

When I play certain .mkv files with subtitles, they'll blink on and off constantly on my screen. I understand that this happens when there is too much happening on the video at one time, but I've heard there's a relatively simple fix for something like this.

I'm using Media Player Classic with the CCCP codec pack with Haali Media Splitter. CCCP has a link to a fix on their Wikipedia, but unfortunately that link seems to be dead.

Thanks in advance for your help.
__________________
Hiroi Sekai is online now   Reply With Quote
Old 2012-01-17, 21:00   Link #2
cyberbeing
Senior Member
 
 
Join Date: May 2006
Location: California
Try xy-VSFilter. Replace the VSFilter.dll in your CCCP Filters directory, run Re-Register Filters on the second page of the CCCP settings application, and you should be good to go.

In recent years, blinking subtitles is usually the result of your CPU being too slow while having pre-buffering enabled in VSFilter 2.40. When pre-buffering is enabled, VSFilter 2.40 will blink instead of de-sync when your CPU is too slow. The issue mentioned on CCCP wiki is about a bug in circa 2005 mkvtoolnix with VFR files. I doubt this is the issue you are having.
__________________
cyberbeing is offline   Reply With Quote
Old 2012-01-17, 21:20   Link #3
Hiroi Sekai
Minna no ojou-sama~♥
*Graphic Designer
 
 
Join Date: Jan 2009
Location: Kelowna, British Columbia
Age: 22
Send a message via Skype™ to Hiroi Sekai
Thanks for the suggestion- I replaced the VSFilter.dll file and checked the Re-Register Filters on the CCCP settings application, but the subs still blink. Am I required to restart my computer before the changes take place?

I do take caution to allow my laptop to focus its CPU on one thing at a time, so I believe the problem might be somewhere else in my settings. Maybe the render settings or somewhere else in the options?
__________________
Hiroi Sekai is online now   Reply With Quote
Old 2012-01-17, 21:24   Link #4
cyberbeing
Senior Member
 
 
Join Date: May 2006
Location: California
Odd, trying doing both re-register filters and reset settings and click apply. Make sure Playback -> Auto-load Subtitles is unchecked in MPC-HC settings. It could be that the MPC-HC internal subtitles renderer is being used instead of VSFilter.

If these are old files, maybe you really do have that other issue. The working link for that topic is here: http://www.anime-legion.com/forum/viewtopic.php?t=1309
__________________
cyberbeing is offline   Reply With Quote
Old 2012-01-17, 21:34   Link #5
Hiroi Sekai
Minna no ojou-sama~♥
*Graphic Designer
 
 
Join Date: Jan 2009
Location: Kelowna, British Columbia
Age: 22
Send a message via Skype™ to Hiroi Sekai
Oh boy, it WAS using the internal renderer. I unchecked the auto-load subtitles, reset the settings and it no longer blinks.

You've been a great help, I thank you.
__________________

Last edited by Hiroi Sekai; 2012-01-18 at 04:56.
Hiroi Sekai is online now   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 18:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.