AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > General > Tech Support

Notices

Reply
 
Thread Tools
Old 2013-02-06, 09:54   Link #1
Eragon
I got you babe.
 
 
Join Date: Aug 2010
Location: Shopping Mall
Age: 21
Unhappy Horrid lag in Dragon Age Origins...

DA:O was running just fine on highest video settings when the first time I played it. Then it got progressively worse. Right now I have lag even on the lowest settings.

Here's my Laptop's configuration,

Processor: Intel Core i3-2310M CPU @ 2.10GHz 2.10 GHz

Internal memory - 4 GB (2.92 GB usable)

Operating system - Windows 7 Professional 32-bit

DirectX version: 11.0
GPU processor: GeForce GT 520M
Driver version: 266.32
DirectX support: 11
CUDA Cores: 48
Core clock: 740 MHz
Shader clock: 1480 MHz
Memory clock: 800 MHz (1600 MHz data rate)
Memory interface: 64-bit
Total available graphics memory: 2262 MB
Dedicated video memory: 1024 MB DDR3
System video memory: 0 MB
Shared system memory: 1238 MB
Video BIOS version: 75.19.12.00.FF
IRQ: 16
Bus: PCI Express x16 Gen2


------------------------------------------------------------------------------------------

There's another peculiar problem. When I update my Nvdia driver to the latest one the Nvidia control panel does not show the option of using the graphics card. I mean this


In the "Preferred graphics processor" tab after the update it only shows "Integrated graphics". But in the older version, as you can see, I can select which one I want. How is this possible? I just recently(like last week) re-installed Win 7 to wipe the slate clean. But the problem is still there.

I would like to think the specs are enough since it worked fine the first time. Any help would be appreciated
__________________
Signature courtesy of rikikai

Last edited by Eragon; 2013-02-06 at 11:13.
Eragon is offline   Reply With Quote
Old 2013-02-06, 13:10   Link #2
sa547
Senior Member
*Author
 
 
Join Date: Oct 2007
Location: Philippines
Age: 38
Try disabling the Integrated Graphics port in the BIOS (or set the shared memory to 0, or select the card as the first); the graphics card is supposed to be assigned as the primary.

Otherwise, some players report that downgrading the drivers (that is, installing the previous drivers that really worked) do wonders more than the new updates (at least until nVidia fixes it in the next version).
__________________
sa547 is offline   Reply With Quote
Old 2013-02-06, 13:25   Link #3
Eragon
I got you babe.
 
 
Join Date: Aug 2010
Location: Shopping Mall
Age: 21
Okay, I'll try that.

Do you have any idea about the other problem? When I update the driver it won't recognize the graphics card in the control panel. I can't choose with which graphics processor to run the program with.
__________________
Signature courtesy of rikikai
Eragon is offline   Reply With Quote
Old 2013-02-06, 19:24   Link #4
sa547
Senior Member
*Author
 
 
Join Date: Oct 2007
Location: Philippines
Age: 38
Oops. Turns out you're using a laptop.

Since OEM drivers sometimes don't get updated by the manufacturer, and often nVidia's mobile drivers don't work right and bring the laptop down into a muck of molasses, the best place to get a really working and updated display driver is here: www.laptopvideo2go.com

Tried it and I was able to have my in-law's Acer laptop play new games like Medal of Honor: Warfighter.
__________________
sa547 is offline   Reply With Quote
Old 2013-02-07, 06:19   Link #5
Eragon
I got you babe.
 
 
Join Date: Aug 2010
Location: Shopping Mall
Age: 21
^ That games worked quite smoothly after installing that driver But the problem with the graphics card option disappearing is still there XD

Meh, as long as the game works I don't care

Thanks a bunch

Oh btw, I love MSGM too
__________________
Signature courtesy of rikikai

Last edited by Eragon; 2013-02-07 at 07:25.
Eragon is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.