AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2007-01-06, 21:48   Link #1
exs120
Uruchai Uruchai Uruchai
 
Join Date: Jun 2006
vlc on mac

While playing a file that has soft subs (like .mkv and .ogm files) using vlc player on a mac, whenever I pause to read the subs, they always disappear after a second or so while paused. This is really annoying because I have to go back to the subtitle part I missed every time I pause. Is there a way on macs to make vlc player keep displaying the subtitles after i've paused it? Help would be very appreciated.
exs120 is offline   Reply With Quote
Old 2007-01-07, 10:01   Link #2
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 28
Short answer: no.

Slightly longer answer: use a better player. VLC's subtitle rendering sucks to hell and back, DO NOT WATCH SOFTSUBBED STUFF IN IT. I suggest using MPlayer instead. More help can be found in this thread.
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline   Reply With Quote
Old 2007-01-07, 18:19   Link #3
exs120
Uruchai Uruchai Uruchai
 
Join Date: Jun 2006
When ever I do play soft sub files, I always try to use mplayer first. The only bad thing about mplayer in my experience is that you can't change the audio track for .ogm but you can display the subtitles. I've read that you can change the default audio track for files through terminal, but I'm completely lost when it comes to that. The only player that I've found able to change audio tracks for .ogm files is vlc. If there were a way to change .ogm audio in mplayer, I'd trash VLC in a second.
exs120 is offline   Reply With Quote
Old 2007-01-08, 05:01   Link #4
Nicholi
King of Hosers
 
Join Date: Dec 2005
Age: 31
You can change tracks in Ogg files now, just not as a default feature in the ogg splitter. You have to use -demuxer lavf. However I'm guessing the libavformat splitter doesn't work with subtitles at all, at least on my win32 builds I can't get subs using it.

Also... this seems to be a major problem with anyone using mplayer. READ THE MANPAGE! You can easily use any parameters you would normally type at the command-line by adding them to the config file. Example for the above Ogg stream switching, just add the line
Code:
demuxer=lavf
However this means the libavformat demuxer will ALWAYS be used when you play files (which is not the default and should not be used in ALL cases), and it should be removed when you aren't playing Ogg files. So if you really choose to be that ignorant about using the command-line you can just constantly edit the config file in this manner. Also you can easily force the nth audio and/or subtitle track on playback with mplayer, or even use the language tags of the tracks (if the tracks have been properly tagged). For the nth track you use -aid (for audio) and -sid (for subtitles), and then -alang and -slang for track languages. It's all quite simple and takes about 2 seconds of reading the manpage in order to figure this stuff out. mplayer has sooooooo much to configure. Anything you think you can't do, you probably can. Maybe not during playback, but beforehand extremely simple. And for proper subtitle rendering, I would say it is worth it .

So I'm guessing you are running into the typical older files, which might have the english audio track first, and japanese second? Simple solution for that is just use -aid 1 (tracks count from zero) which will always force the 2nd audio track. Magix, you are done. Once again if you put those parameters into the config file they will always be on. This is where the usefulness of using the CLI comes in, or using profiles in the config file (also nifty).
Nicholi is offline   Reply With Quote
Old 2007-01-10, 10:26   Link #5
Arimfe
SharpenerOfTheBoxcutter
 
 
Join Date: May 2006
Location: where Grudge is Greatest, Rancour Endless and Malice Eternal(at school^^;;)
Quote:
Originally Posted by exs120 View Post
Is there a way on macs to make vlc player keep displaying the subtitles after i've paused it?
This isn't only a problem with Macs as far as I have noticed, VLC in Windows also displays this...#"!%..silliness. The older versions at least, I recently poked at VLC 0.8.6a in win32 and it seems they have fixed that problem, so try to update you VLC.

If that's doesn't do the the trick, then it's possibly because I tweaked some weird settings I don't remember. I suggest you ask here instead: http://forum.videolan.org/
They should be more in the know about VLC than any of us.
Arimfe is offline   Reply With Quote
Old 2007-01-11, 21:40   Link #6
exs120
Uruchai Uruchai Uruchai
 
Join Date: Jun 2006
I figured out a much easier way w/ out using the command line. Just go into Mplayer preferences, check additional parameters, and input -aid 1. Thanks for all your help.
exs120 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 00:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.