AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Tech Support

Reply
 
Thread Tools
Old 2007-05-18, 08:53   Link #1
guest
guess
 
 
Join Date: Nov 2003
Japanese file names can't be opened?

I have image files or manga files that are in Japanese with a japanese file name, like xxxx.jpg. My computer can't open them unless I rename them to English, whatever it is. Is there a way to keep the original names and still functional? I am running on Windows XP. Thanks.
__________________
guest is offline   Reply With Quote
Old 2007-05-18, 09:03   Link #2
Vallen Chaos Valiant
Logician and Romantic
 
 
Join Date: Nov 2004
Location: Within my mind
Age: 33
Quote:
Originally Posted by guest View Post
I have image files or manga files that are in Japanese with a japanese file name, like xxxx.jpg. My computer can't open them unless I rename them to English, whatever it is. Is there a way to keep the original names and still functional? I am running on Windows XP. Thanks.
If you have the original XP disc, couldn't you install the Japanese font into the OS from the disc? XP really should be able to handle all this...

And if you watch as much Anime and check anime news as often as I do, it would be best if your computer can display Japanese fonts anyway.^_^
__________________
Vallen Chaos Valiant is offline   Reply With Quote
Old 2007-05-18, 09:19   Link #3
Jinto
Asuki-tan Kairin ↓
 
 
Join Date: Feb 2004
Location: Fürth (GER)
Age: 33
Which application exactly cannot open them? Paint?
In system somewhre (sorry have a german Windows) one can enable east asian language support (maybe that will make things more compatible).
Jinto is offline   Reply With Quote
Old 2007-05-18, 14:07   Link #4
Nicholi
King of Hosers
 
Join Date: Dec 2005
Age: 31
Some applications just won't support unicode filenames and paths (ACDSee, grr how many more versions will it take!). MSPaint should be one of the few which does in fact work, though obviously that isn't much of an useful app to view images.

I haven't really located a nice unicode app myself for viewing images.
Nicholi is offline   Reply With Quote
Old 2007-05-18, 16:28   Link #5
GHDpro
Administrator
*AnimeSuki Site Staff
*Moderator
 
 
Join Date: Jan 2001
Location: Netherlands
Age: 35
Sigh. It's been discussed before.

Control Panel -> Regional and Language Options -> Advanced tab.

Then set the "Language for non-Unicode programs" to Japanese.

Even ACDSee won't have much of a problem with Japanese filenames then (although it still won't "see" unicode folders inside ZIP files).
GHDpro is offline   Reply With Quote
Old 2007-05-18, 17:41   Link #6
Jinto
Asuki-tan Kairin ↓
 
 
Join Date: Feb 2004
Location: Fürth (GER)
Age: 33
Before you can do that, you'll have to activate the east asian language support (otherwise you cannot choose japanese)
Jinto is offline   Reply With Quote
Old 2007-05-18, 19:54   Link #7
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
Quote:
Before you can do that, you'll have to activate the east asian language support (otherwise you cannot choose japanese)
And you'll need the win XP disc to install the fonts
__________________


Place them in a box until a quieter time | Lights down, you up and die.
WanderingKnight is offline   Reply With Quote
Old 2007-05-18, 19:58   Link #8
Jinto
Asuki-tan Kairin ↓
 
 
Join Date: Feb 2004
Location: Fürth (GER)
Age: 33
That is correct *g*

yet there might exist some programs, that just do not want to support double width characters... no matter what
Jinto is offline   Reply With Quote
Old 2007-05-18, 20:15   Link #9
guest
guess
 
 
Join Date: Nov 2003
Done and it worked. Thanks.

While I was changing the setting, I noticed that you can only set it to one non-Unicode program. Why can't I set it to as many programs as possible?
__________________
guest is offline   Reply With Quote
Old 2007-05-18, 20:33   Link #10
Ledgem
Love Yourself
 
 
Join Date: Mar 2003
Location: Northeast USA
Age: 28
Quote:
Originally Posted by guest View Post
Done and it worked. Thanks.

While I was changing the setting, I noticed that you can only set it to one non-Unicode program. Why can't I set it to as many programs as possible?
I presume you meant "Language" instead of "Program" and the reason is because the system, by default, treats the programs with that language support. If you had multiple languages going, it'd be quite a mess - certain programs will only run properly under certain language support, and the computer doesn't know which language the program matches with (if it did, you wouldn't need to set such a thing).

If you're working with programs like that and you can't be bothered to always be changing the language, get Applocale (free from Microsoft). It lets you run a program under a certain non-unicode-support language, and you can create a shortcut so that the program always runs under Applocale. Pretty nifty.
__________________
Ledgem is offline   Reply With Quote
Old 2007-05-18, 22:18   Link #11
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
Quote:
If you're working with programs like that and you can't be bothered to always be changing the language, get Applocale (free from Microsoft). It lets you run a program under a certain non-unicode-support language, and you can create a shortcut so that the program always runs under Applocale. Pretty nifty.
Maybe it's just me, but I could never get that damn thing to work fine on me -_-; (not that I tried too hard, either).
__________________


Place them in a box until a quieter time | Lights down, you up and die.
WanderingKnight is offline   Reply With Quote
Old 2007-05-19, 04:28   Link #12
GHDpro
Administrator
*AnimeSuki Site Staff
*Moderator
 
 
Join Date: Jan 2001
Location: Netherlands
Age: 35
Now the only problem of changing the "Language for non-Unicode programs" setting is that some applications (like Nero CD-DVD Speed) take it as a cue to turn their entire interface into Japanese, which can be quite annoying. But obviously you can always turn the setting back.

Also I've noticed all backslashes are turned into yen signs in filepaths. But that only looks odd: it doesn't really cause any problems.

Last, somebody mentioned a MS tool called "AppLocale" before, which supposedly allows you to pick seperate languages for different applications, but I'm not sure if it applies here (where the filenames are in Japanese, as then the Windows Explorer might also need to play along).
GHDpro is offline   Reply With Quote
Old 2007-05-19, 11:18   Link #13
Ledgem
Love Yourself
 
 
Join Date: Mar 2003
Location: Northeast USA
Age: 28
WinXP should have support for foreign characters regardless; if it can't access those files, it's indicative of the fact that East Asian Languages aren't installed. I don't believe that the non-unicode support has anything to do with it with the exception of certain programs (for example, I noticed that Winamp had some difficulty accessing files with Japanese in the title - this was fixed when running it under AppLocale with Japanese as the language). Explorer doesn't seem to have a problem.

Also, you can use AppLocale if your system is under Japanese settings. It sounds silly, but as GHDPro pointed out, some programs change their entire language settings based on that non-unicode support setting. Running those programs under "English" through AppLocale usually fixes it and makes them behave normally.
__________________
Ledgem is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 18:19.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
We use Silk.