AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Tech Support

Notices

Reply
 
Thread Tools
Old 2004-06-26, 04:40   Link #1
smilealwiz
yallo
 
Join Date: May 2004
VirtualDub Problem - Tag 0055

Hi all.

I have a problem playing an xvid file in VirtualDub. I always get the error "Error initializing audio stream decompression: The requested conversion is not possible. Please check to see that you have the required codec."

Point is, according to G-spot, I have all the required codecs, 3 of them in fact - MPEG Layer-3 Decoder, LAME MP3 Codec, Fraunhofer IIS MPEG Layer-3 Codec.

VirtualDub shows the audio compression as "unknown - Tag 0055". I read on forums that this implies it's in MP3 format, but even though I have MP3 codecs, VirtualDub still refuses to play the file.

Have been trawling the net and reading through many forums the entire day and at the end of my wits now.
Would really really really appreciate anyone who could enlighten me on this please.

Thanks a million!
smilealwiz is offline   Reply With Quote
Old 2004-06-27, 00:15   Link #2
KeinikuSuki
鶏肉がとてもおいしい。
 
Join Date: May 2004
Send a message via ICQ to KeinikuSuki
First, are you using VitualDubMod?

Second, the decoder my work, but V-Dub is too pansy to try it. Open the "Audio" menu and select "Error mode..." Select "Decode even if the result may be garbled" and hit "OK".
KeinikuSuki is offline   Reply With Quote
Old 2004-06-27, 07:24   Link #3
smilealwiz
yallo
 
Join Date: May 2004
nope.. I'm not using VirtualDubMod..

And erm.. I wish your method would work.. but then VirtualDub doesn't allow me to select that choice of "decode even if result may be garbled". Only "report all errors" is selectable...

appreciate your help though...

any more ideas please?
smilealwiz is offline   Reply With Quote
Old 2007-04-08, 02:59   Link #4
Aranael
Junior Member
 
Join Date: Apr 2007
For solving the problem, only using virtualdub, here's the solution:

1)Open VirtualDub (do not open the video file)
2)Go to the "Hex Editor" under the "Tools" menu.
3)Under the "Edit" menu, make sure the option "Enable AVI field assist" is checked.
4)Go to "open" under the "file" menu and browse for your video .
5)Search (in aprox the 18 line -may vary from file to file-) for "strf".
6)By clicking on that line (or the next one) hex values you will be able to see a reference in the hint, at the bottom of the editor called "wBitsPerSample: bits/sample, for PCM only". This is composed by 2 two digits values (for ex "10 00").
7)Change the values to "00 00".
8)Save and exit the Hex.
9)be sure to thanks "squid 80", from the VirtualDub Unofficial Support Forum (he is Gods son in law)
Aranael is offline   Reply With Quote
Old 2007-04-08, 04:35   Link #5
GHDpro
Administrator
*Administrator
 
 
Join Date: Jan 2001
Location: Netherlands
Age: 35
1) Why are you replying to a TWO YEAR OLD thread? There is no point to this, as the original poster likely already found the answer, or the answer is no longer relevant.

2) Afaik the problem in question is with AVI files containing either AC3 or AAC audio, which is technically illegal (afaik) anyway. Better convert it to MKV with MKVMergeGUI and then rip it to pieces with MKVExtractGUI, as it's way easier that way. Then with the separate video track (AVI, no sound) and manually converted audio (AC3/AAC->MP3) you can reassemble and further process with VirtualDub easily.
GHDpro is offline   Reply With Quote
Old 2008-02-23, 23:59   Link #6
maxwell-x
Junior Member
 
Join Date: Feb 2008
in june of 2k4, smilealwiz had a "tag 0055" problem. in april of 2k7, aranael posted a reply. the same day, ghdpro asked him why. in short, i'm why. even though the original post was almost 3 yrs ago and the reply was 2 yrs later, today, 11 mos later, aranael's reply solved my problem. so, the reason for replying to any post is that sometime down the road, someone will google the problem and come across the thread. thx much, aranael ; the hex edit worked flawlessly.
maxwell-x is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.