AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2008-07-10, 09:12   Link #741
sk3
Member
 
Join Date: Sep 2007
Age: 27
Recently i got a problem with Mplayer OS X and font rendering. I don't know if anyone got it but here's what i did to solve my problem.

Open terminal and type:

open .mplayer

assuming that you are on your home directory (by default, it is) open the fonts folder and delete/move everything to another folder.

Try to open the file again.

It worked for me with Itazura na Kiss, it was rendering a complete different font (conflict maybe?).

This was the first time i got it, and i felt the need to share this information if anyone got the same problem as me.

Btw, my mplayer font folder was OVER 150MB (something like 186MB i don't remember now).
sk3 is offline   Reply With Quote
Old 2008-07-11, 17:37   Link #742
foxleaps
Junior Member
 
Join Date: Jul 2008
Quote:
Originally Posted by pho_king View Post
I'm on a powerbook g4, 1.6 ghz and 1gb ram, and i've followed the directions for mplayer and quicktime+perian, but the playback of 1280x1080p vidoes, specifically Gattai's Macross Frontier is laggy. i've set mplayer to drop frames, but alas it is still slow in some parts. is my computer too slow to run these HD releases?
I am experiencing the same problems -- the smaller .mkv files work alright in both Quicktime & MPlayer, but 1280 just won't play without lagging. Sometimes the playback will come promisingly close to being in sync, only to begin subtitle/video/audio delay after a few minutes. SO FRUSTRATING.

So, possibly my imac is too slow as well? I'm on a G5, 2 GHz PowerPC.
What do you say?
foxleaps is offline   Reply With Quote
Old 2008-07-11, 20:35   Link #743
sk3
Member
 
Join Date: Sep 2007
Age: 27
Just for curiosity what video module are both of you using? i used Mplayer OS X module in the past but i now use core video because of the multi monitor setup i have. You might try that because it's using some APIs from OS X and might help somehow.
sk3 is offline   Reply With Quote
Old 2008-07-11, 21:22   Link #744
foxleaps
Junior Member
 
Join Date: Jul 2008
Quote:
Originally Posted by sk3 View Post
Just for curiosity what video module are both of you using? i used Mplayer OS X module in the past but i now use core video because of the multi monitor setup i have. You might try that because it's using some APIs from OS X and might help somehow.
Frankly speaking: I have not the slightest idea. However, if you actually suspect that the video module might play a role in this issue, then I might look into it. How do I go about this?
foxleaps is offline   Reply With Quote
Old 2008-07-11, 21:35   Link #745
sk3
Member
 
Join Date: Sep 2007
Age: 27
By default it uses Mplayer OS X. To change it it's easy

Open Mplayer OS X, go to preferences, then video & audio. You will see the video output module. Just select CoreVideo (BETA) (don't mind the BETA thing) and click ok. open a file a test it. you may also play with other preferences to see if you can get any kind of boost to your videos.
sk3 is offline   Reply With Quote
Old 2008-07-13, 23:20   Link #746
Takeru
Jag äter idioter
*Graphic Designer
 
 
Join Date: Dec 2005
Location: Vereinigte Staaten
Age: 24
Send a message via AIM to Takeru Send a message via Skype™ to Takeru
Here's one for you. I'm trying to watch Mahou Tsukai ni Taisetsu na Koto - Natsu no Sora episode 1 and neither MPlayer, QuickTime Pro (w/ Perian) or VLC can seem to get it right.

So far, MPlayer shows the font style correctly. QuickTime almost gets the font positioning correct, and VLC is just confused to hell. Any idea what the issue could be?

Spoiler for screenshot of all three:
__________________
Takeru is offline   Reply With Quote
Old 2008-07-14, 08:20   Link #747
Nonezumi
Member
 
 
Join Date: Apr 2007
Quote:
Originally Posted by Takeru View Post
Here's one for you. I'm trying to watch Mahou Tsukai ni Taisetsu na Koto - Natsu no Sora episode 1 and neither MPlayer, QuickTime Pro (w/ Perian) or VLC can seem to get it right.

So far, MPlayer shows the font style correctly. QuickTime almost gets the font positioning correct, and VLC is just confused to hell. Any idea what the issue could be?
Well, why VLC doesn't handle is is pretty obvious; VLC just doesn't handle SSA/ASS subtitles at all well and so should be avoided if at all possible.

I've checked out that file on my Mac; given I'm on a slightly more recent build of MPlayer than has been released here at the moment, it acts exactly as Perian does; the subtitles start in the mid-right of the screen.

This would suggest that in part that something has been altered on MPlayer's source since the last released build here. I note there was a patch toward the end of March, which would tie in with when I last worked on it...

Bottom-line is without asking a Windows user to check if the file renders properly, it's difficult to make a judgement call.

Digging through the source, it seems the file is encoded as a V4+ subtitle file.

The Kanji style is set on a 270 degree rotation which would make sense given the odd angle it's being rendered, and is set as 5 on Alignment. This suggests it's _supposed_ to appear centre-justified at the top, but I'm no SSA expert.

Though quite often, the OP/EDs seem to me the one area where Fansubtitlers seem to prefer hard-subs to soft-subs.
Nonezumi is offline   Reply With Quote
Old 2008-07-14, 10:31   Link #748
thr
Member
 
Join Date: Sep 2004
Quote:
Originally Posted by Takeru View Post
Here's one for you. I'm trying to watch Mahou Tsukai ni Taisetsu na Koto - Natsu no Sora episode 1 and neither MPlayer, QuickTime Pro (w/ Perian) or VLC can seem to get it right.
Spoiler for Renders correctly on Windows ...:

Spoiler for Not looking so good ...:
thr is offline   Reply With Quote
Old 2008-07-21, 01:59   Link #749
Mr VacBob
yotsuba channel
 
Join Date: Oct 2004
Location: GA
Age: 26
Send a message via AIM to Mr VacBob
It uses some weird Windows thing where you can draw font letters sideways if you put @ at the beginning of the font name. It's not in Perian because, uh, I forgot about it. I'll try to get around to it if I remember.
Mr VacBob is offline   Reply With Quote
Old 2008-07-22, 21:38   Link #750
iamtetsuo
Thinking Different Member
*Fansubber
 
 
Join Date: Jan 2006
Location: Santa Cruz, CA
Age: 30
Send a message via AIM to iamtetsuo
I suppose I should drop by here and let people know that I really don't check this site as often as I used too. In fact I haven't even watched any anime since several months ago (I even went to an anime convention and didn't watch any). I am quite well aware that the OP is long overdue for a complete overhaul due to many changes since I last updated it. My life is changing right now, I'm out of college now and starting off a new career. So, I don't really see myself having the time to keep current with all the new updates available for Mac.

So my suggestions are: that somebody else starts up a new thread, or that a moderator implement updates, or a moderator gives someone else the power to edit the first post of this thread (is that even possible?). I really enjoyed updating this thread, and all the thanks I got for starting it. But I know that this thread needs someone with more free time to give it the justice it deserves.
__________________
Currently Watching: Keroro Gunsou, Lovely Complex, Baccano!
iamtetsuo is offline   Reply With Quote
Old 2008-07-27, 17:23   Link #751
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
I've been working on the osx gui of mplayer and completely reworked the preferences dialog.

Some new options are, for example:
- Take screenshots
- Deinterlace filter(s)
- More postprocessing options
- Options for ass and embedded fonts
- Audio and video equalizers

Here are some screenshots:


You can download the current version here:
http://files.rubbishchute.net/animes...X_ext-rev3.dmg

This build includes the official rc2 mplayer binary. I recommend to compile your own version, you can find out how in this thread:
http://forums.animesuki.com/showthread.php?t=68394
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Old 2008-07-29, 01:43   Link #752
HaloZero
Junior Member
 
Join Date: Jul 2008
Wow, good job anime_layer, thanks.

I was planning on working on it but first time developing for mac, didn't realize all the stuff was in the mac bundle and not in source. ><.

Last edited by HaloZero; 2008-07-29 at 02:00.
HaloZero is offline   Reply With Quote
Old 2008-07-29, 22:18   Link #753
rougheo
Junior Member
 
Join Date: Jul 2008
when playing mkv's on mplayer, is there a way for me to have the subtitles always on so that i dont ever have to hit J every time i play an episode?
rougheo is offline   Reply With Quote
Old 2008-07-29, 22:44   Link #754
Mr VacBob
yotsuba channel
 
Join Date: Oct 2004
Location: GA
Age: 26
Send a message via AIM to Mr VacBob
Quote:
Originally Posted by Mr VacBob View Post
It uses some weird Windows thing where you can draw font letters sideways if you put @ at the beginning of the font name. It's not in Perian because, uh, I forgot about it. I'll try to get around to it if I remember.
Actually, that can't be it, since that doesn't affect the line rotation. Haven't figured that part out yet.
Mr VacBob is offline   Reply With Quote
Old 2008-07-30, 08:49   Link #755
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
Here's a test build with mplayer compiled from the latest SVN:
EDIT: http://files.rubbishchute.net/animes...X_ext-rev4.dmg


Only works on Leopard and Intel. Feedback if it's workin appreciated!
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.

Last edited by anime_layer; 2008-08-01 at 15:56.
anime_layer is offline   Reply With Quote
Old 2008-07-30, 20:24   Link #756
Gamer5389
Junior Member
 
Join Date: Aug 2007
The build has been working excellently for every video I've managed to throw at it. One curious thing is the that the OSD doesn't work perfectly. The seek bar and the icon (pause, play, etc) show up but things like languages while scrolling through subtitles, chapter titles, and the progress time don't appear.
Gamer5389 is offline   Reply With Quote
Old 2008-07-31, 07:51   Link #757
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
I've compiled all libraries by hand and got all compiled to the Tiger SDK. Here's the updated build:
EDIT: http://files.rubbishchute.net/animes...X_ext-rev4.dmg


Haven't gotten to do a universal binary, will try that next.
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.

Last edited by anime_layer; 2008-08-01 at 15:57.
anime_layer is offline   Reply With Quote
Old 2008-07-31, 12:01   Link #758
MEDiAHORAN
RYL addicted
 
Join Date: May 2008
Location: Sweden
Quote:
Originally Posted by anime_layer View Post
Here's a test build with mplayer compiled from the latest SVN:
http://files.rubbishchute.net/animes...-rev4-test.dmg

Only works on Leopard and Intel. Feedback if it's workin appreciated!
I followed your compiling guide but it returned an error code 1 when I tried to play anything so I stuck with Mohammeds build.

So I am glad that you posted this new version, and it works like a charm I deleted mohammed with addzapper and deleted the config files so now it's fresh! Thanks a lot man!

Although I have the same problem as the previous version I simply create an input.conf file and type RIGHT seek +3
LEFT seek -3 but it does not skip 3 seconds forward nor backward so I had to delete the file.

Any ideas?

Last edited by MEDiAHORAN; 2008-07-31 at 12:17.
MEDiAHORAN is offline   Reply With Quote
Old 2008-08-01, 13:04   Link #759
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
anime_layer, I'm using that build you made and it's working fine, I was wondering how can I change audio modes? In the previous one that was floating around I used to press J and that would let me change the subtitles, and with the audio I'd use -aid and the number of the track.

How does it work for your compiled version?

I also noticed that, if I press J it changes the subtitles but it doesn't show up any text (like the version floating around used to do).

Edit: I just saw the parameters thing in the preferences, so I'm working it again with -aid.
Ryoujin is offline   Reply With Quote
Old 2008-08-01, 15:54   Link #760
anime_layer
Senior Member
*Graphic Designer
 
 
Join Date: Feb 2003
Location: Zürich, Switzerland
Send a message via ICQ to anime_layer
Managed to cross-compile to ppc. Works in rosetta so I guess it's fine but haven't got a real ppc mac anymore to try. Haven't made a version with altivec disabled. Hope nobody minds.

Also fixed the OSD font. Fontconfig is now activated unconditionally (seems like it's not forced anymore with -ass) and the font selection has been adapted, too. Hope it works for everyone.

http://files.rubbishchute.net/animes...X_ext-rev4.dmg
__________________
MPlayer OSX Extended (en) | nimmermehr (de) | sttz (de) | last.fm
Life is a game whose first rule is: This is not a game, this is dead serious.
anime_layer is offline   Reply With Quote
Reply

Tags
fansubs, mac, wiki candidate

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.