AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2006-10-03, 18:33   Link #1
CxFusion3mp
Junior Member
 
Join Date: Oct 2006
Black Screen when playing videos, Audio works fine...

Hello, First time poster, long time user of video solutions on this forum. I've seen a couple of posts on this but none that have a solution that worked for me.

Sunday night my videos were playing just fine. Then I updated my vid-card drivers and DirectX to fix some fps problems in a game. The next time I opened one of my videos, the window opened and the sound worked fine, Video played but the screen was black.

I've tried a system restore to before the point I did the installs, went even a month back. Still broken. Uninstalled all my codecs, installed CCCP/ ffdshow, still nothing plays. reset my video card, nada. reinstalled drivers and still nothing. Reinstalled MediaPlayer Classic/DivX etc... nothing there either.

I've tried MediaPlayer10, Media Player Classic, Real Player, DivX, Zoomplayer, VLC...

Seems to be a global problem, all videos and all video players experience the same thing. The ONLY videos that don't have this problem, are ones i created on my webcam, not really sure why this is the case.

Another funny thing, If i open a file in media player classic, then while it's running, i open the file in VLC. VLC works! but if i open it in VLC first VLC has the same problem. Same for the reverse, VLC first/media player classic works...


Any help will be much appreciated. Thanks in advance!
CxFusion3mp is offline   Reply With Quote
Old 2006-10-03, 21:31   Link #2
Nicholi
King of Hosers
 
Join Date: Dec 2005
Age: 31
From the description of having two players open it sounds exactly like an overlay issue. You should be able to note the same effect using the same player opened twice (MPC can have multiple instances open at once I know). The first player is using an overlay (and not working so you don't see anything), the second is not running with an overlay and just going directly to your CPU. Your webcam videos probably are decoded by some funky codec that only outputs RGB, thus no overlay.

However a System Restore should have solved all the issues. First I would recommend using the MPC's CCCP again, and try changing the video renderer used Options->Playback->Output->DirectShow Video. Perhaps one of them will be more friendly, try VMR7/9 and Overlay Mixer (should be default).

Otherwise I would suggest you reinstall DirectX 9.0c again, also try re-installing WMP10 (solves DirectShow issues of weirdness). And most importantly find the good set of video card drivers you used before. The problem most likely stems from the video card drivers.

If none of this still works, and you are despairingly hopeless, you can trix your way around the problem by forcing all ffdshow output to RGB (which will use no overlay). FFDShow Video Config->Output->Uncheck all YUV colorspaces.
Nicholi is offline   Reply With Quote
Old 2006-10-04, 00:46   Link #3
CxFusion3mp
Junior Member
 
Join Date: Oct 2006
Thanks a bunch, Changed MPC to VMR9 and it worked. dl'ing MP10 worked too for it. hadn't done that yet since i never use it. I usually stick w/ VLC and MPC. VLC is still messed up but i can deal w/ that until I find a solution. Good to be able to watch bleach again

And btw, after the restore i had my old drivers and directX. still didn't work, somehow it saved setting i guess. I did do a driver rollback for my vid card. DirectX won't let you uninstall. System restore is the only way I could find, when i tried to install again it just told me i had the version and quit. I think back in 2002 or so there was a program that forced it to remove but thats a bit out of date.
CxFusion3mp is offline   Reply With Quote
Old 2007-10-26, 15:56   Link #4
whiterabbit79
Junior Member
 
Join Date: Oct 2007
I had the same problem, drove me nuts trying to find out what was going on. Google found this forum post (thanks google) and it solved all my problems. Thanks a lot nicholi for the advice.

I registered here just to say this
whiterabbit79 is offline   Reply With Quote
Old 2009-05-14, 16:49   Link #5
limnedbob
Junior Member
 
Join Date: May 2009
Thank you AnimeSuki forum. In VLC Tools>Preferences>Show settings-All>Video Uncheck 'Overlay video output'. Will try and fix this properly later, but for now, thanks for my Battlestar Galactica back
limnedbob is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 23:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.