AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Closed Thread
 
Thread Tools
Old 2004-01-07, 03:34   Link #1
acidic
Junior Member
 
Join Date: Jan 2004
Location: San Francisco and Tokyo
ffdshow crashes explorer.exe

If I click on DivX AVI video files in a folder, then unselect the file by clicking an empty space in the folder window, explorer.exe crashes. I did not have any of these problems before installing ffdshow alpha (200030523). I tried uninstalling all of my codecs (DivX, XVid, Elecard Mpeg2 decoder) and reinstalling ffdshow by itself, but it still causes explorer.exe to crash. The only way I can prevent this is by uninstalling ffdshow altogether.

Here's what I have:

1.4GHz Athlon XP
512MB DDR memory
ATI All In Wonder Radeon 7500 64MB
Windows 2000
Windows MP 9
Media Player 6.4
RealOne Player
ATI Multimedia Center 8.8

Is there a known problem with any of these components?
Thanks in advance.
acidic is offline  
Old 2004-01-07, 06:22   Link #2
Esperchld
Photographer
 
Join Date: Apr 2003
Location: Ohio, USA
Age: 33
Well, I can tell you that you aren't the only one with this problem, except I can make it do it with just the DivX drivers installed. You might be able to make it stop doing it by forcing it to switch which codec is used to decode the file, granted I don't know how to do this except on a file by file basis. I can however, rule out the ATI card, WMP 9.0, and ATI MMC, as other than those, my system is identical.
Esperchld is offline  
Old 2004-01-13, 14:16   Link #3
CrossScar
Inactive Member
 
Join Date: Jan 2004
Me to.

I've got the very same problem as you. It is not your system. I'm running on WinXP. I noticed I didn't have this problem untill I did all of the uninstalling and installing of FFdshow.

I even posted on Xivd.org because in the error message, when I view it, it gives me a Xivd.dll for the error. It's always Xivd in mine.

But after coming here and seeing some ppl are having the same issues as I am, then I'm thinking its because of this lil Program. A program which has been great in all its supposed to do, but a reall pain in the butt with explorer.

Maybe they'll be some answers
CrossScar is offline  
Old 2004-01-13, 14:25   Link #4
ElvenPath
a step away from heaven
*Moderator
 
 
Join Date: Nov 2003
Location: U.K. London
Are you all using the latest ffdshow alpha release?

http://prdownloads.sourceforge.net/f...3.exe?download
__________________
I want a unicorn.
ElvenPath is offline  
Old 2004-01-13, 14:47   Link #5
Shift_
Senior Member
 
Join Date: Nov 2003
Location: Down Under
The question is WHY do you have FFDshow installed?

All it does is playback Divx and Xvid and other video formats WITH it's BUILT in codecs.

I just have Divx. Xvid, Vobsob, Mkv and ogm and AC3 installed.

the FFDshow codec doesn't look as clean as the normal Divx and Xvid codecs. I've done comparisons, when opening a divx file in the divx player (using the divx codec) vs WMP (using FFDshow) and after uninstalling FFDshow in WMP (using divx codec) and the divx codec > FFDshow same thing with Xvid.
Shift_ is offline  
Old 2004-01-13, 14:54   Link #6
CrossScar
Inactive Member
 
Join Date: Jan 2004
Quote:
Originally Posted by Shift_
The question is WHY do you have FFDshow installed?

All it does is playback Divx and Xvid and other video formats WITH it's BUILT in codecs.

I just have Divx. Xvid, Vobsob, Mkv and ogm and AC3 installed.

the FFDshow codec doesn't look as clean as the normal Divx and Xvid codecs. I've done comparisons, when opening a divx file in the divx player (using the divx codec) vs WMP (using FFDshow) and after uninstalling FFDshow in WMP (using divx codec) and the divx codec > FFDshow same thing with Xvid.
I've got it installed because it seemed like a better way to view videos, Since I've installed it I've never had a problem viewing any video I've DLed. Now when I had 6 + applications I did have problems. I searched for Codec after Codec to try and get things to play that wouldn't. So rather then having 6 programs to play each file and about 5 different Codec packs (which still don't play everything) I uninstalled them and gave the FFDshow a try. My problem is the crashing of explorer it causes. =/

Unfortunately, I've found that Divx doesnt support everything. Maybe with these anime episodes here, but not with other types of video

And I do have the most updated version, I still have the original install.exe
CrossScar is offline  
Old 2004-01-13, 15:03   Link #7
flammie
White Dragon
 
Join Date: Dec 2003
Just out of curiosity, do you have the preview pane open? One possibility is that explorer is trying to preview the file using ffdshow and is having problems. Try turning off the preview function in explorer and see if that helps.
flammie is offline  
Old 2004-01-13, 15:13   Link #8
Sour-Do
Senior Member
 
 
Join Date: Nov 2003
Location: SWTOR Ajunta Pall
Send a message via ICQ to Sour-Do Send a message via AIM to Sour-Do Send a message via MSN to Sour-Do Send a message via Yahoo to Sour-Do
Quote:
Originally Posted by acidic
If I click on DivX AVI video files in a folder, then unselect the file by clicking an empty space in the folder window, explorer.exe crashes.
I had this weird problem once. It seemed to happen because more than 1 codec was fighting to decode the same file. I fixed my problem by uninstalling the suspected codecs and re-installing them. Specifically for me, it was a contention between DivX and XviD.

-- Sour-Do
AnimeMuyou!
Sour-Do is offline  
Old 2004-01-13, 15:45   Link #9
NoSanninWa
Weapon of Mass Discussion
*Fansubber
 
 
Join Date: Feb 2003
Location: New York, USA
Quote:
Originally Posted by flammie
Just out of curiosity, do you have the preview pane open? One possibility is that explorer is trying to preview the file using ffdshow and is having problems. Try turning off the preview function in explorer and see if that helps.
Interesting hypothesis, but I doubt it is accurate since it happens when he unselects the video. I am interested though if you could tell me how to turn the preview function on and off? I'd like to know how to change it, but can't recall ever having come across that option.
__________________

There's not that fine a line between willing suspension of disbelief and something just being stupid.
NoSanninWa is offline  
Old 2004-01-13, 16:33   Link #10
CrossScar
Inactive Member
 
Join Date: Jan 2004
Quote:
Originally Posted by NoSanninWa
Interesting hypothesis, but I doubt it is accurate since it happens when he unselects the video. I am interested though if you could tell me how to turn the preview function on and off? I'd like to know how to change it, but can't recall ever having come across that option.

As of right now the crashing of explorer has been halted after some fiddling. Now whether or not it'll hold out untill the morning I can't be sure. But I decided to go and install Divx, just to "have" on the computer. So far I've not had any issues with it crashing... yet. and I still have FFdShow installed. ^.^
CrossScar is offline  
Old 2004-01-13, 16:39   Link #11
flammie
White Dragon
 
Join Date: Dec 2003
Quote:
Originally Posted by CrossScar
As of right now the crashing of explorer has been halted after some fiddling. Now whether or not it'll hold out untill the morning I can't be sure. But I decided to go and install Divx, just to "have" on the computer. So far I've not had any issues with it crashing... yet. and I still have FFdShow installed. ^.^
Just so other people know (I'm curious too), how did you solve the problem?
flammie is offline  
Old 2004-01-13, 16:42   Link #12
flammie
White Dragon
 
Join Date: Dec 2003
Quote:
Originally Posted by NoSanninWa
Interesting hypothesis, but I doubt it is accurate since it happens when he unselects the video. I am interested though if you could tell me how to turn the preview function on and off? I'd like to know how to change it, but can't recall ever having come across that option.
Hmm, there seems to be two ways to do it (in NT 4).

Uncheck view->as web page (annoying)

view->customize this folder->create or edit html document
and comment out or edit the media player stuff. (the stuff after "if (want media)")
flammie is offline  
Old 2004-01-13, 17:15   Link #13
CrossScar
Inactive Member
 
Join Date: Jan 2004
To Flammie

Quote:
Originally Posted by flammie
Hmm, there seems to be two ways to do it (in NT 4).

Uncheck view->as web page (annoying)

view->customize this folder->create or edit html document
and comment out or edit the media player stuff. (the stuff after "if (want media)")

Flammie ~

I'm testing it. I do not like Divx because of codec problems I've had in the past. Because of the Xivd.dll error I was getting. I decided to try and install Divx player and so far it has not crashed my explorer. I still am using the ffdshow and will continue to keep it. but so far it looks like as long as it sees Divx on the system its not crashing. I'm still testing it doing allot of things with explorer and files to try and make sure it's not going to suddenly crash.

so far so good
CrossScar is offline  
Old 2004-02-02, 15:33   Link #14
Draikan7
Member
 
Join Date: Jul 2003
preview window crashing

I just installed the latest version of unified codec pack. I tried many other codecs to fix my explorer.exe crashing. Seems like this fixed it but now anytime i even touch an avi file of my anime, it would freeze up my comp and i have to do a altctrldel to end my anime folder. I fixed this by turning off the preview window that loads up that mini image on the left side. But anyone know why it does this or how to fix it so i can turn it back on?

Last edited by NoSanninWa; 2004-08-30 at 20:26. Reason: Threads merged
Draikan7 is offline  
Old 2004-02-02, 15:41   Link #15
flammie
White Dragon
 
Join Date: Dec 2003
Quote:
Originally Posted by Draikan7
I just installed the latest version of unified codec pack. I tried many other codecs to fix my explorer.exe crashing. Seems like this fixed it but now anytime i even touch an avi file of my anime, it would freeze up my comp and i have to do a altctrldel to end my anime folder. I fixed this by turning off the preview window that loads up that mini image on the left side. But anyone know why it does this or how to fix it so i can turn it back on?
Just out of curiosity, what is this "unified codec pack"? Most codec packs are bad because the codecs in the pack end up conflicting each other.
flammie is offline  
Old 2004-02-02, 17:03   Link #16
Draikan7
Member
 
Join Date: Jul 2003
I believe the real name is called dTomoyo? It seems to work fine except w/ the problem I'm having. Not sure what the cause of my problem is tho.
Draikan7 is offline  
Old 2004-02-02, 17:44   Link #17
flammie
White Dragon
 
Join Date: Dec 2003
Quote:
Originally Posted by Draikan7
I believe the real name is called dTomoyo? It seems to work fine except w/ the problem I'm having. Not sure what the cause of my problem is tho.
It seems the english version of the pack doesn't have ffdshow included. Have you tried uninstalling it and using only ffdshow (+ ac3, etc)?
flammie is offline  
Old 2004-02-02, 18:07   Link #18
ElvenPath
a step away from heaven
*Moderator
 
 
Join Date: Nov 2003
Location: U.K. London
A thread on this issue has already been started here.
__________________
I want a unicorn.
ElvenPath is offline  
Old 2004-02-02, 21:24   Link #19
JOJOS'STAR
Ero~Kairin! ^-^ Yeay!
*Graphic Designer
 
 
Join Date: Nov 2003
Location: ~ Montreal
pff....too tired to right anything..I've already explained it all in the other thread. Try this.

Quote:
Actualy this problem comes from a single file.

I had the same problem with a XVid1 format. Every time the miniature loaded even before playing the video it maked my explorer crash. Find the bad data by putting your files view in "details". then your page should load normaly whitout any crash then look for the Xvid1 in your library of video . Search the proprieties to know what codec was used. Get rid of this video. If this is your problem, installing the new xvid codec version is useless. This should work it did for me. As to know if your problem is the exact same.. but I suggest you try .
Or simply view the entire thread. http://forums.animesuki.com/showthread.php?t=2269
__________________
JOJOS'STAR is offline  
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.