AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > Support > Tech Support

Notices

Reply
 
Thread Tools
Old 2008-05-26, 05:03   Link #1
jedinat
フリーター
 
 
Join Date: Dec 2005
Age: 29
I heed to somehow force disable hardware acceleration or DirectDraw on Vista

Vista/my video card drivers/whatever have all ganged up on me and won't let me do something so simple as to disable hardware acceleration. (because of course there could never be any good reason for me to do so, right? ugh...)

I'm playing Planescape: Torment and from what I gather DirectDraw is causing the glitchy boxes that plague my spell effects. The 10 or so forum topics I've found on the subject all conclude triumphantly with solutions that don't apply to me for whatever reason. (makes me want to kill the happy bastards) The most offensive one is the 'disable hardware acceleration or directdraw' solution. Vista's display properties and the dxdiag tool taunt me by showing me settings I can't access. Windows tells me my display driver doesn't allow me to change hardware acceleration, and dxdiag uselessly shows me DirectDraw is enabled with no option to disable it.

Is there any way to bypass this? Perhaps some sort of insanely useful 3rd party program? My video card is an ATI Radeon HD2600pro. I've browsed ATI Tool's options and tweaks to no avail.

*edit: "heed" in the topic title should obviously be "need"
jedinat is offline   Reply With Quote
Old 2008-05-26, 05:28   Link #2
Ending
Senior Member
 
 
Join Date: May 2004
I would imagine you need to find the security settings of the OS and disable them or go to the control panel -> display properties > advanced. On WinXP there is a slider in one of the tabs.
Ending is offline   Reply With Quote
Old 2008-05-26, 08:03   Link #3
Epyon9283
Geek
 
 
Join Date: Dec 2005
Location: New Jersey
Age: 31
Send a message via ICQ to Epyon9283 Send a message via AIM to Epyon9283
It has nothing to do with security settings (if UAC is enabled it'd do the normal prompt for elevated privileges). Apparently some drivers don't allow you to mess with acceleration settings. The ATI drivers I have for the x1600 on my laptop don't allow me to change the setting.
Epyon9283 is offline   Reply With Quote
Old 2008-05-26, 15:53   Link #4
jedinat
フリーター
 
 
Join Date: Dec 2005
Age: 29
Quote:
Originally Posted by Wordplay View Post
I would imagine you need to find the security settings of the OS and disable them or go to the control panel -> display properties > advanced. On WinXP there is a slider in one of the tabs.
There is idealy a hardware acceleration slider in the Troublshooting tab on Vista. My problem is that it has been disabled. I've been trying to figure a registry fix but I've been so far unsuccessful. Like Epyon9283 wrote, the ATI driver seems to disable the function. There should be some way to run a program with DirectDraw disabled...
jedinat is offline   Reply With Quote
Old 2008-05-26, 16:47   Link #5
jedinat
フリーター
 
 
Join Date: Dec 2005
Age: 29
I did it! lol, after spending way too much time on this, I finally came across Microsoft's Application Compatibility Toolkit, which among other things provides tons of compatibility options--one of them being "ForceDirectDrawEmulation."
jedinat is offline   Reply With Quote
Old 2008-05-27, 08:36   Link #6
Ending
Senior Member
 
 
Join Date: May 2004
Well, that's what you get for jumping to the Vista-bandwagon: compatibility toolkits.
Ending is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 13:28.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
We use Silk.