AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Reply
 
Thread Tools
Old 2008-06-23, 19:46   Link #1
Valk1317
Junior Member
 
Join Date: May 2008
Linux sub woes

thought id give linux a shot for my desktop since now i dont use it for my primary anymore since getting a tablet pc.
All it does is torrent and do light internet work/photo touchups.

Got it all up and running fine with ubuntu 8.04 which runs awsome. im curious how other people have got their linux setups to work with some of the more modern anime though. it all plays just fine, but the stylized subtitles of most groups do not work in gstreamer or mplayer. vlc even fails here.
this wouldnt bother me so much if it wasnt for files with multiple subs. ie, macross frontier 12, with the news person and the character conversation.
all the above mentioned apps will either flicker between subs rapidly, or overlap them.

its probably a minor nitpick, but ive been trying to dicipline myself to not go into my xp install if i really dont have to *ie, im not gaming or i dont NEED photoshop* but i actually had to reboot last night just to watch this episode lol.

I will say though. ive made a lot of attempts at linux as a main os and hardy is probably the most positive so far. runs fast in x64 with 4gb ram and all the whistles on heh. does pretty much everything else so if i could fix this, id be happy.
Valk1317 is offline   Reply With Quote
Old 2008-06-23, 20:00   Link #2
Proto
Knowledge is the solution
 
 
Join Date: Jan 2004
Location: U. of Pittsburgh, Previously in Mexico City.
Age: 29
This is my mplayer config file. (place it under ~/.mplayer/

Code:
# Write your default config options here!


monitoraspect=16:9 # use this for widescreen monitor! non-square pixels

#subtitle code
#Truetype fonts rock! (sudo apt-get msttcorefonts)
font=/usr/share/fonts/truetype/ttf-mgopen/MgOpenModataBold.ttf
#font=/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf

ffactor="10" #black outline
sub-bg-alpha="0" #background color ala closed captions
sub-bg-color="7" #to white
subfont-text-scale="3" #truetype font scaling
subfont-outline=2.0
subfont-blur="1" #Slight blur
spuaa=4
subpos="95" #By default subtitles are too low
subalign="2"
double="yes"
ffactor="10"

ass=1
embeddedfonts=1
fontconfig=yes
subcp=cp1251


slang=en,eng,spa,sp
alang=jp,jap

#autoq=100
#vf=pp=de,hqdn3d

#stop-xscreensaver=yes
geometry=50%:50%

lavdopts=fast=1:skiploopfilter=nonkey:threads=2
It will use stylized soft subbed subtitles (though you have to have the msfonts installed for the fonts flag to take effect), and it has some flags directed at optimizing the playing speed(the lavdopts line). If you have a question about some of the options feel free to ask.
Proto is offline   Reply With Quote
Old 2008-06-23, 20:37   Link #3
Valk1317
Junior Member
 
Join Date: May 2008
Thank you very much for the helpful reply =) they definitly look better *although still too big* but im still stuck with overlapping subs sadly =(

ah, im still all noob with linux though. took me a while to find the conf file in question and make the changes.
Valk1317 is offline   Reply With Quote
Old 2008-06-23, 21:11   Link #4
Proto
Knowledge is the solution
 
 
Join Date: Jan 2004
Location: U. of Pittsburgh, Previously in Mexico City.
Age: 29
Play with the subfont-text-scale parameter to increase or decrease the font size. Other than that, what do you refer with overlapping? Could you provide a screenshot?

Trivia: When using directory names, '~' normally refers to the home directory.
trivia2:this page has a comprehensive list of answers for common mplayer problems.

Last edited by Proto; 2008-06-23 at 21:29.
Proto is offline   Reply With Quote
Old 2008-06-23, 22:44   Link #5
Valk1317
Junior Member
 
Join Date: May 2008


in mpc, these subs are split in top and bottom of the screen. its not a REALLY big deal, but it makes following busy scenes kinda rough heh.

im sure i can fix the text size myself heh. i fiddled with the settings and got rediculously small text which was no good. just reinstalled the package.

Last edited by NightWish; 2008-08-20 at 17:23. Reason: Thumbnails _please_.
Valk1317 is offline   Reply With Quote
Old 2008-06-24, 03:57   Link #6
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
By the way, you can grab a screenshot just by pressing Print Screen. No need to open the GIMP or things like that. Though in GNOME you have no way of saving it as a JPG (PNG only) so you'd have to use the GIMP to convert it to JPG if you want it to be suitable for the web.

By the way,

Code:
ass=1
embeddedfonts=1
fontconfig=yes
correct-pts=1
That's all I have in my mplayer config file regarding subs. Proto's config file is missing the last "correct-pts" entry... I don't know how it might affect it.

A comment on the UNIX way of handling applications' configurations:

Everything in UNIX is a file. Save for binaries (regular executables and object files), every file is editable with a regular text editor (gedit, included in GNOME, is a very powerful one--miles ahead from the ridiculously basic Notepad). In UNIX, most applications save their configurations (in editable text files) in a hidden directory, starting with a dot, under the user's home directory. Open up the console and do:

Code:
user@box:~$ ls -a
...and you'll see lots of those hidden folders appear. The command ls lists the current directory's files, and the option -a tells it to display everything, including hidden files.

There are several advantages to this type of configuration--one of them is the fact that there's a strong separation between application content and application configuration. Even if you uninstall mplayer, the ~/.mplayer directory is kept, and were you to reinstall it, it would take the same configuration as before (there's a slight exception regarding a particular option, --purge, when using apt to uninstall a program). That's a huge advantage when reinstalling a system (supposing you used a separate partition for the /home/ folder). Another advantage is that if you have an application that is behaving strangely, removing the configuration folder may solve it pretty neatly without the need of reinstalling--that is, of course, supposing the issue has to do with its configuration.

By the way, I don't know how are you handling the installation of programs, but please do everything through the repositories. This is not Windows--you don't need to go look for the software on the developers' homepage.

If you want more help with Ubuntu and Linux in general, feel free to drop by the relevant thread in the Tech Support forum.
__________________


Place them in a box until a quieter time | Lights down, you up and die.

Last edited by WanderingKnight; 2008-06-24 at 04:12.
WanderingKnight is offline   Reply With Quote
Old 2008-06-24, 04:42   Link #7
Miles Teg
Senior Member
 
Join Date: Dec 2005
Location: Le Mans, France
You have a problem with the config of your MPlayer, for me the episode looks like that :



My config file only have that :

embeddedfonts=yes
ass=yes

You should look at the gui.conf file you should see this line ass_enabled = "yes" gmplayer use both the config and gui.conf file.
Miles Teg is online now   Reply With Quote
Old 2008-06-24, 19:45   Link #8
Valk1317
Junior Member
 
Join Date: May 2008
alright, added all that and it still doesnt show up like that. in fact, adding these tags did nothing seemingly =(

Code:
#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.


##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=xv

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
fs=no

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes


##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=pulse,alsa,

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Specify default audio codec (see -ac help for a list).
ac=mad,


##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0     plain white fonts
# 0.75  very narrow black outline (default)
# 1     narrow black outline
# 10    bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
slang = en

# DVD: Play English audio tracks if available.
#alang = en


# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"

#Disable joystick support
#It seems to cause very odd problems on laptops
#With accelerometers (See LP: #75925)
nojoystick = yes

#subtitle code
#Truetype fonts rock! (sudo apt-get msttcorefonts)
font=/usr/share/fonts/truetype/ttf-mgopen/MgOpenModataBold.ttf
#font=/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf

ffactor="10" #black outline
sub-bg-alpha="0" #background color ala closed captions
sub-bg-color="7" #to white
subfont-text-scale="3" #truetype font scaling
subfont-outline=2.0
subfont-blur="1" #Slight blur
spuaa=4
subpos="95" #By default subtitles are too low
subalign="2"
double="yes"
ffactor="10"

ass=1
embeddedfonts=1
fontconfig=yes
correct-pts=1
subcp=cp1251


slang=en,eng,spa,sp
alang=jp,jap
the config.

this is the /etc/mplayer/mplayer.conf correct?
Valk1317 is offline   Reply With Quote
Old 2008-06-24, 20:48   Link #9
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
Umm, no. The configuration file is found in:

/home/*username*/.mplayer/config

That is, in .mplayer under your home folder.
__________________


Place them in a box until a quieter time | Lights down, you up and die.
WanderingKnight is offline   Reply With Quote
Old 2008-06-24, 22:21   Link #10
Valk1317
Junior Member
 
Join Date: May 2008
alright, i feel like an idiot, but ive used linux for like 2 days, i guess its normal lol.

edited the CORRECT config and the gui.conf and it works fine =) thank you guys. im sure ill be around still asking more questions.
Valk1317 is offline   Reply With Quote
Old 2008-06-25, 00:56   Link #11
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
Don't worry, you're coming from a world were nothing makes sense into somewhere were you can find saner standards. It's completely normal to be dazzled by such a bright beam of light (j/k)

As always, remember that you can ask any of us Linux users in AS, and you'll find lots of help.
__________________


Place them in a box until a quieter time | Lights down, you up and die.

Last edited by WanderingKnight; 2008-06-25 at 01:07.
WanderingKnight is offline   Reply With Quote
Old 2008-06-25, 19:14   Link #12
Valk1317
Junior Member
 
Join Date: May 2008
im not really sure what the resolve to use linux was for me this time. ive kinda tip toed around it a few times before, got installed and messed with it some, but i used to game a lot more. now all the desktop has to do is troll anime and do some graphic editing from time to time.

I use my Tablet pc for everything else, but sadly, it isnt linux friendly. I mean, i have ubuntu on it and all configured, but cellwriter is no subsitute for the tablet tip. also, none of the little things like sofbuttons or autorotate work.

ah well. ill mess with it a little at a time. at least wine doesnt eat too much performence for the essentials, like opencanvas and photoshop.
Valk1317 is offline   Reply With Quote
Old 2008-08-20, 14:13   Link #13
theblackestmage
Junior Member
 
Join Date: Aug 2008
Quote:
Originally Posted by WanderingKnight View Post
Don't worry, you're coming from a world were nothing makes sense into somewhere were you can find saner standards. It's completely normal to be dazzled by such a bright beam of light (j/k)

As always, remember that you can ask any of us Linux users in AS, and you'll find lots of help.
Like the OP I just switched to Ubuntu Hardy, and this post solved the problems I've been having with playing anime subs on Ubuntu. However I have two questions I would like to ask regarding MPlayer if it is not too off-topic.

I can't find in preferences where to click to auto-load subtitles. All there is is an unchecked box that says "Disable subtitle auto-loading."

Lastly, I have yet to find a preference menu in Ubuntu Hardy that allows for me to set program defaults to open files with.

Thanks in advance for any help that I might receive regarding these issues.
theblackestmage is offline   Reply With Quote
Old 2008-08-20, 14:33   Link #14
WanderingKnight
Gregory House
*IT Support
 
 
Join Date: Jun 2006
Location: Buenos Aires, Argentina
Age: 25
Send a message via MSN to WanderingKnight
Quote:
I can't find in preferences where to click to auto-load subtitles. All there is is an unchecked box that says "Disable subtitle auto-loading."
You're probably using the outdated gmplayer GUI for mplayer... But I don't understand what your problem is. Perhaps there is a problem, but there's a different way of solving it (which is usually the case with transitioning to different applications). What exactly is the issue? Gmplayer should autoplay every subtitle.

Quote:
Lastly, I have yet to find a preference menu in Ubuntu Hardy that allows for me to set program defaults to open files with.
I don't use GNOME anymore, but I'm sure it's found under Properties in the right-click context menu for any file.
__________________


Place them in a box until a quieter time | Lights down, you up and die.
WanderingKnight is offline   Reply With Quote
Old 2008-08-20, 17:18   Link #15
SeijiSensei
AS Oji-kun
 
 
Join Date: Nov 2006
Location: Mucking about
Age: 64
Like WK, I'm not a GNOME user either, but you might try installing SMPlayer, which is "desktop-agnostic" and has GUI support for many things that are less obvious in gmplayer.

I used smplayer for a while, but I've reverted back to KPlayer since I use the KDE desktop. In KPlayer you can enter command-line options that are passed to mplayer when it's invoked. Here's my list:

-ass -slang en -alang jpn -lavdopts skiploopfilter=all -vf screenshot

The first iitem provides support for ASS soft subtitles, while the next two select the default subtitle and audio language channels. The -lavdopts parameter speeds up H.264 decoding, though you might find "nonkey" works better for you than "all" on some H.264 videos. The last item adds the screenshot "filter" to the display chain, so you can pause a video and press "s" to save a screen shot. Mplayer has a huge array of options. Try typing "man mplayer" at a command prompt, and you'll see what I mean. I only recently learned about the skiploopfilter option from reading a posting here on AS.

As WF says, adding the -ass-font-scale parameter will allow you to change the size of the subtitles. I used to include this with a value of 0.9, but lately I've found the default font sizes of the shows I watch perfectly acceptable.

A good test of how well your mplayer implementation handles H.264 decoding and ASS subtitles is to watch episode four of the BSS version of Kure-nai. The OP runs at a high bitrate and is very demanding; without the skiploopfilter setting above it won't run cleanly on my Pentium-D computer. At 14:30 in the episode there's a three-way conversation during which the subtitles are placed in different locations on the screen. mplayer with the settings above places those subtitles in the proper locations for me.
__________________
SeijiSensei is offline   Reply With Quote
Old 2008-09-17, 23:42   Link #16
Valk1317
Junior Member
 
Join Date: May 2008
alright back to linux and with a new issue =).

i run two monitors which i got to work alright with full accelleration and all. good to go. but when i try to fullscreen a video on the second monitor it offsets the video and doesnt fill the screen. is there a way to force Mplayer to full the screen, or start fullscreen on that display?
Valk1317 is offline   Reply With Quote
Old 2008-09-18, 07:45   Link #17
SeijiSensei
AS Oji-kun
 
 
Join Date: Nov 2006
Location: Mucking about
Age: 64
You might try playing with the -monitoraspect parameter. My daughter has a laptop that's in 16:10. Until I used -monitoraspect 16:10 mplayer wouldn't fill the screen properly. You might need to change something like -monitorpixelaspect if your monitor doesn't have square pixels, though that's much less common. There's also a -geometry setting which might be useful if you need to locate the viewing window in a particular location. These settings are all in the "Video Output Options" section of the mplayer man page.
__________________
SeijiSensei is offline   Reply With Quote
Old 2008-09-18, 19:59   Link #18
Valk1317
Junior Member
 
Join Date: May 2008
well i think part of the problem is that im running two different monitor aspects... primary is 16x10, 1680x1050. that works fine if i fullscreen on my main. second display is 16x9 with 1360x768.

everything on the primary works fine, but fullscreening on the secondary crops the image, cutting out the subtitles and some of the picture.
Valk1317 is offline   Reply With Quote
Old 2008-09-18, 21:40   Link #19
SeijiSensei
AS Oji-kun
 
 
Join Date: Nov 2006
Location: Mucking about
Age: 64
You might try setting up a second mplayer.conf file with the 16:9 aspect ratio and use the -input switch to tell mplayer to use it when you're watching that monitor. Another option might be to use a shell like smplayer set to use the alternate configuration.

What happens if you launch mplayer from the command line with -monitoraspect 16:9 when you're on the second monitor?
__________________
SeijiSensei is offline   Reply With Quote
Old 2008-09-18, 22:02   Link #20
Valk1317
Junior Member
 
Join Date: May 2008
Im not sure what you mean by start on the second monitor. i ran it from the command line;

mplayer -monitoraspect 16:9 -fs yes Desktop/frontier15

it loads on the primary display, 1680. is there a way to force it to start on the second screen?
i triedd adding some screen stuff to the line but didnt work.
Valk1317 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:18.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
We use Silk.