AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > AnimeSuki & Technology > Playback Help

Notices

Reply
 
Thread Tools
Old 2011-10-07, 07:13   Link #481
Cpuroast
Member
 
 
Join Date: Mar 2009
Quote:
Originally Posted by pigoz View Post
Its not automated and I don't have a system to test it so its likely I will screw up. It will take me way too much time and I don't have much of it at the moment. I don't even have the 10.5 SDK installed.

Not gonna happen, sorry. They can always compile it themselves if they have homebrew (it's fairly automated). Supporting 5(6?) years old hardware is not really my thing: hell, even Apple gave up on it.

Btw: I still have to work on the DTS stuff. Might as well put out a release without it because it's taking too long. Maybe Sunday.
That's ok,

It seems anime_layer is back in action, he released Rev15 Test1 a little while ago on sparkle update in the beta channel. It comes with an up to date mplayer2 build with 10bit, drops ppc support, but I suspect it's 10.5 Intel 32bit compatible.

It is missing ordered chapter support so I still use your builds.

Thanks again!
Cpuroast is offline   Reply With Quote
Old 2011-10-07, 12:38   Link #482
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
Quote:
Originally Posted by Cpuroast View Post
That's ok,

It seems anime_layer is back in action, he released Rev15 Test1 a little while ago on sparkle update in the beta channel. It comes with an up to date mplayer2 build with 10bit, drops ppc support, but I suspect it's 10.5 Intel 32bit compatible.

It is missing ordered chapter support so I still use your builds.

Thanks again!
If it's mplayer2 it supports ordered chapters! Mispelled?
pigoz is offline   Reply With Quote
Old 2011-10-09, 00:18   Link #483
Cpuroast
Member
 
 
Join Date: Mar 2009
Quote:
Originally Posted by pigoz View Post
If it's mplayer2 it supports ordered chapters! Mispelled?
It supports 10bit playback, so I'd imagine it's mplayer 2, unless that was also implemented in the older mplayer tree.

But I did try it with a 10bit file with ordered chapters and it failed to load the linked file. Where as your build loaded it just fine.

Just enable beta update check and it will pull rev 15 test1 and you can see for yourself.
Cpuroast is offline   Reply With Quote
Old 2011-10-09, 02:27   Link #484
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
I don't have mplayerosx extended installed: I use mplayer2 with no gui
Anyway 10bit was introduced in the original mplayer too.
pigoz is offline   Reply With Quote
Old 2011-10-17, 12:25   Link #485
yeahitschris
Senior Member
 
 
Join Date: Aug 2006
Can anyone help me with my MPlayer? When I try to watch Fate/Zero, this is what I get:

Spoiler:


I am on Snow Lepoard still; MPlayer OSX Extended rev 14 (1410)

These are the binaries I have installed:



But when I try to use MPlayer2 binary, I cannot watch anything

__________________
yeahitschris is offline   Reply With Quote
Old 2011-10-17, 16:30   Link #486
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
Quote:
Originally Posted by yeahitschris View Post
Can anyone help me with my MPlayer? When I try to But when I try to use MPlayer2 binary, I cannot watch anything
try mplayer-git-2011-07-29.zip from http://code.google.com/p/mplayerosx-...downloads/list
pigoz is offline   Reply With Quote
Old 2011-10-18, 07:12   Link #487
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
Got a new computer with Lion so I'm a bit lost as of which binary from pigoz to download. Any help?
Ryoujin is offline   Reply With Quote
Old 2011-10-18, 12:49   Link #488
yeahitschris
Senior Member
 
 
Join Date: Aug 2006
Quote:
Originally Posted by pigoz View Post
try mplayer-git-2011-07-29.zip from http://code.google.com/p/mplayerosx-...downloads/list
Ah, okay thank you. I downloaded that one last time but there was an "update" and I just updated it thats why. Thanks pigoz!

Quote:
Originally Posted by Ryoujin View Post
Got a new computer with Lion so I'm a bit lost as of which binary from pigoz to download. Any help?
Go here and download: 2011-10-09 (which is for Lion).

http://code.google.com/p/mplayerosx-...downloads/list
__________________
yeahitschris is offline   Reply With Quote
Old 2011-10-18, 20:14   Link #489
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
Quote:
Originally Posted by yeahitschris View Post
Go here and download: 2011-10-09 (which is for Lion).

http://code.google.com/p/mplayerosx-...downloads/list

Thanks, yeahitschris!
Ryoujin is offline   Reply With Quote
Old 2011-10-20, 14:48   Link #490
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
Is there someone with snow leopard who wants to help me with some testing?
pigoz is offline   Reply With Quote
Old 2011-10-21, 14:02   Link #491
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
No clue why, but for some reason some anime episodes are coming thru without sound. This is using latest Pigoz build, under 10.7.2.

If I run the same episode thru VLC the sound works, tho.
Ryoujin is offline   Reply With Quote
Old 2011-10-21, 16:52   Link #492
yeahitschris
Senior Member
 
 
Join Date: Aug 2006
Quote:
Originally Posted by pigoz View Post
Is there someone with snow leopard who wants to help me with some testing?
I will if you tell me what I need to do. I am still on SL, too cheap to update to Lion
__________________
yeahitschris is offline   Reply With Quote
Old 2011-10-21, 17:05   Link #493
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
Quote:
Originally Posted by Ryoujin
No clue why, but for some reason some anime episodes are coming thru without sound. This is using latest Pigoz build, under 10.7.2.

If I run the same episode thru VLC the sound works, tho.
By chance are you using passthrough? Can you name some examples files?

Quote:
Originally Posted by yeahitschris View Post
I will if you tell me what I need to do. I am still on SL, too cheap to update to Lion
Cpuroast was faster, thank you anyway
pigoz is offline   Reply With Quote
Old 2011-10-21, 19:20   Link #494
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
Quote:
Originally Posted by pigoz View Post
By chance are you using passthrough? Can you name some examples files?

Sending you a PM.
Ryoujin is offline   Reply With Quote
Old 2011-10-21, 21:14   Link #495
Ryoujin
What?
 
 
Join Date: Nov 2007
Location: The house besides yours
Age: 30
So it seems that the problem was that I pressed mute by error (somehow) and even tho I could raise or lower the computer's volume, the preference kept working on all the files I'd try. Good game, heh.
Ryoujin is offline   Reply With Quote
Old 2012-04-08, 05:02   Link #496
print screen
Junior Member
 
Join Date: Aug 2006
I'm using version 14 and the list of audio tracks available doesn't always show. Also, when I hit shift+3 I end up disabling audio instead of switching audio tracks. Is there a new shortcut for switching audio tracks? How can I get the list of audio tracks to always show all tracks available?
print screen is offline   Reply With Quote
Old 2012-04-09, 03:19   Link #497
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
does this happen only with certain files? could be a problem with the demuxer.
pigoz is offline   Reply With Quote
Old 2012-04-10, 04:15   Link #498
print screen
Junior Member
 
Join Date: Aug 2006
-Shift+3 disabling audio happens for ALL files.
-In order for me to switch audio tracks, I have to use the menu.
-The menu doesn't always show all the available audio tracks. I'll keep reloading the file until the menu shows all audio tracks.
-I don't know what a demuxer is.

While these situations does not prevent me from watching anime the way I want to, it's inconvenient.

I also still have a 2009 version of Mplayer installed (not OSX Extended, just regular Mplayer) if that makes a difference.
print screen is offline   Reply With Quote
Old 2012-04-11, 04:13   Link #499
pigoz
YUKI.N>
 
 
Join Date: Mar 2009
Location: Milan, Italy
Send a message via MSN to pigoz Send a message via Skype™ to pigoz
I guess you are using mplayerosx from 2009. If it has menus it can't be the standalone version. Anyhow this is most likely the problem: you are running a version that is way too old and possibly buggy.

I suggest you download mplayerosx extended with the mplayer2 binary provided here: http://code.google.com/p/mplayerosx-builds/.

FYI: The demuxer is a module inside mplayer/ffmpeg that allows it to read a file and understand which tracks it is composed of.
pigoz is offline   Reply With Quote
Old 2012-04-11, 06:58   Link #500
print screen
Junior Member
 
Join Date: Aug 2006
- I have both version 14 of OSX Extended and a 2009 version of Mplayer.
- I mentioned that I have both in case they may be interfering with each other.
- 2009 Mplayer does not have this audio track problem.
- Version 14 of OSX Extended does have this problem.
- I have the mplayer2 binary for version 14 of OSX Extended. Doesn't work for me.
- By "menu", I meant the bar at the top of the screen where you click on "movie" then scroll to "audio" and select your audio track.
print screen is offline   Reply With Quote
Reply

Tags
wiki candidate

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
We use Silk.