View Full Version : How to run multiple clients of a MMO at the same time?

2011-09-13, 20:07
So I'm wondering if this is possible, and if it is, how? By simply running the clients at the same time is not possible as the clients use some programs to prevent this (gameguard etc.) so I'm wondering if there was a way around for this. I do not have a laptop or other computers so that is out of the question.

What I'm mainly thinking here is to use virtualbox or virtualmachine, but is this actually possible? And if it is, how do I do it? I've once tried to do something with Virtualbox but I had no idea what I was doing and it didn't work out.

The reason for this is simple ; I want to farm certain things in MMO's, and of course, being in a party of my own increases the chances for me to get it rather than running with someone else. As I can solo the dungeons, there's no need to play with the other clients. In this particular game (Elsword) 3 people or more means 2x drops, but I'm tired of running with other people and everyone else always getting the good stuff and leaving me emptyhanded.

If possible with VB/VM, I assume this takes a lot of memory, but I should be covered as I have 16GB of 1600mhz memory.

So any suggestions or is it really impossible?

2011-09-13, 20:36
I personally find VMWare better at doing 3D games in VM's compared to VirtualBox.

It seems that Elsword works well with VMWare from a quick Google since most threads seemed to be asking how to multiclient without using VMWare. What other games do you intend to play? Some games do detect if they are running in a VM and there are occasionally fixes to make stuff work again.

2011-09-13, 20:58
Elsword is actually 2D sidescroller so it's not exactly 3D. But as I said, I'm not too familiar with programs like this and I am fine with using any. At the moment I only intent to play Elsword, and perhaps Dragonica at a later time if I return to that game.

Could you perhaps instruct me as how VMWare works and how does one use it to run at least 2 instances of Elsword, plus the one on Windows? Also I was wondering if there was a risk of an IP ban due then as playing, multiple clients would be using the same IP? Though I doubt that's really something to worry about with Elsword as I am playing from Finland even though their game is supposed to be NA Only and ip blocked. But for other games..

2011-09-13, 21:30
Lots of 2D things use 3D Acceleration and DirectX support anyways. Maplestory is another example of this.

Most likely you will have the same IP for both computers no matter what settings you have since the router will be NAT'd anyways.

VMWare is pretty self explanatory. VMWare Player should suit your needs fine so I wouldn't recommend buying Workstation. Make a new Windows VM, be sure to enable 3D acceleration, VMWare will help you through the Windows installation process, when its finished install DirectX and your game.

Make sure the VM is shut down. To make copies, just create a copy of everything in a new directory, open it up in VMWare and it will ask if you Copy/Move, choose Copy.

btw, if you don't need to do anything to get past the IP ban, Finland is probably included in the region covered by the North America localization. I know Maplestory North America is for NA and all regions without their own localizations.

2011-09-13, 21:36
Nah, Elsword actually has IP blocks in place but for some reason Finland is not part of it. I actually asked this from the support (stupid of me, yeah) and they said something that the game is strictly NA only and players outside NA cannot play the game. I do wonder why they didn't ban me after I asked such thing, though.

Anyhow, I am creating a workstation right now.. Seems to take quite a while to make a 40GB virtual disk. Not sure if lower amount of space would have done the job but it recommended 40GB to me so I went with it. So how do I install files, programs and stuff to the virtual disk? Do I need to install graphic card drivers to the disk, too? Also can I just copy/paste the elsword installation file (and updated files from my own Elsword folder) somehow?

I didn't see an option to enable 3D acceleration by the way, and I chose the advanced way for creating a new workstation too :x.

2011-09-13, 21:47
Wouldn't running it Sandbox-ed work? I did this once for one of my localized MMO, though I haven't tried this extensively with other games.

2011-09-13, 22:33
Space isn't preallocated for the disk by default so using less space wouldn't speed it up noticeably.

I'm not sure what you mean by the advanced way. Open up VMWare Player, File>Create New Virtual Machine and follow the wizard through. At the last step hit customize hardware and Accelerate 3D should be under Display. It'll boot up, install Windows, install VMWare Tools, DirectX, the game.

Do not install your graphic card drivers since VMWare has its own virtual display adapter so its not your card that the VM is seeing.

Just copy paste the install file for game and install. I doubt just copypasting the game over will work though, unless you can install it on a USB drive and have it work on other computers.

2011-09-13, 22:46
Ok now I need serious help. From what you googled, it seemed as if Elsword was going to work on VMWare? But it does not. It says '' Sorry, this application can not run under Virtual Machine ''. Googling this message stumbled me upon to this (http://communities.vmware.com/message/591497#591497) forum thread, among others, but frankly I have no idea what they're talking about there other than possible and potential solutions. Could you perhaps decipher them for me and help me out here or am I really out of luck? x.x

Edit : Figured it out, partially anyway. vmx file in the folder where the windows is installed, and I edited it thru wordpad. Trying it now, but if it still doesn't work, can I assume Elsword is not meant to be played under VM? :(

.. Aand it doesn't work. I found few other commands to try out, too, but it still doesn't work. On one Elsword forum someone was certainly running Elsword on VMWare though with Windows XP VM.. I was trying it on Win7.. hmm. I'll try again with XP, but I doubt it works as it didn't for others either, except that one person x.x. There was also someone who typed in that thread '' You can always close the handle that keeps the client from duplicating itself.. But I'm not gonna be the person that hunts for that. '' .. What's that supposed to mean? What handle? How to close? Is that even gonna help?

Edit 3 : From another glance, that person was playing in the korean Elsword server, which uses X-Trap. I have no idea which protection system the US version of Elsword uses...

Oh and I'm using the workstation, not the player, if that makes any difference.

Edit 4 : Ok this is getting really annoying and way beyond my understanding. The game would appear to '' work '' in VM XP because it doesn't give me the error but instead xtrap launches. However, this is where i hit the wall. Xtrap crashes immediately with an error '' A crash has been detected by BugTrap '' and the game doesn't launch. Running the game in administrator results in same problem. I haven't installed DirectX because it gives me an error that it can't be installed on the current operating system even though I did download one that said it was for Windows XP. Not sure if the DirectX is relevant to the X-Trap buuut.. any ideas? Tried reinstalling etc. ofc yet to no avail..

2011-09-14, 07:00
It could be that the NA version of that game uses a different version of X-trap that somehow stops the game from running in a virtual machine environment or it could be the game itself is crashing and it's a element of X-trap that is detecting it and closing the game.

Also is the virtual XP up to date and with all service packs installed (since if you have SP3 installed you should have a almost current version of directx 9.0c installed).

2011-09-14, 08:07
I tried with SP1 because someone in some forum said SP3 isn't working. Now attempting with SP2, and then will try with SP3.. I still don't get why I can't install DirectX to the Sp1 though. I also tried updating that SP1 but the Windows Update wasn't working for some reason.

2011-09-14, 14:58
They obviously don't want you playing it in a VM.

The entire handle thing seems to be directly modifying the game executable or the anti-hack program which will probably get you in big trouble.

If its XTrap, to quote from this thread (http://ubuntuforums.org/archive/index.php/t-1069960.html)
CrossFire MMOFPS has switched from GameGuard to XTrap

Does NOT currently work natively under wine or linux, but does under a properly configured VMWare Player.

Configure with:
svga.vramSize = 268435456
monitor_control.restrict_backdoor = "true"
isolation.tools.getPtrLocation.disable = "true"
isolation.tools.setPtrLocation.disable = "true"
isolation.tools.setVersion.disable = "true"
isolation.tools.getVersion.disable = "true"
monitor_control.disable_directexec = "true"

Maplestory uses GameGuard, but it gives other insights into countering the game protection against running inside VM's

2011-09-14, 15:30
Yeah, I already have those commands, should have mentioned it. Without those commands under any Windows, I get the message that it can't be run under VM. If I add those commands, I still get the error in Win7, but instead X-Trap crashes in WinXP. So in WinXP those lines bypass the VM check (probably) but X-Trap still crashes for unknown reason. I doubt it matters whether I use VMWare Workstation or Player?

I don't suppose you know how to edit the handle thing? Sure enough, it may get me in trouble but I just want to see if it works. (The X-Trap should notice any modifications to the file so if I modified x-Trap, wouldn't it just patch and revert to how it was?).

Also I'll try again and try to use some information from the forum you linked me, however I ran into another problem. I added the lines to the VMX file (some weren't there), and now the VM doesn't boot up and says Library Error or something like that. I did not take a backup of the vmx file (stupid..), I can no longer start the VM. Any ideas what I can do to restore the vmx file or do I seriously need to reinstall the VM again and download all the damn updates on the XP to make it SP3?

Edit : Well I deleted the VM as I could not get it work through creating new VM to the same location even though it says on VMWare forums that's the way to create one... Sigh, now creating a new one -_-.

2011-09-14, 16:20
It shouldn't matter whether you are using player or workstation.

I have analyzed how to hack GameGuard under Windows in an attempt to do the same under Linux to run Maple via WINE. Don't have any experience with XTrap. Even so, I don't think revealing how to do so would be allowed on this forum.

Its possible, especially if you know roughly what were the settings you created the VM with. The settings it changed shouldn't cause problems though, did you make sure to remove the spaces between "isolation." and "tools"? Try that first.

2011-09-14, 17:02
edit : All solved, multiclienting works perfectly. Now all I need is a script/program to send keystrokes to the other two clients at the same time I control the one on my Windows. This case is solved, but if anyone reading this knows how to get this done, please drop me a pm :)

2011-09-17, 00:40
This thread would be very helpful, as I'm thinking of running a VM with XP on and my favorite MMO, while running under Win7 64. Thanks for some of the tips. :)