AnimeSuki Forum (
-   Tech Support (
-   -   NVIDIA Control Panel issue (

Rising Dragon 2012-03-21 23:00

NVIDIA Control Panel issue
So I seem to have lost access to my NVIDIA control panel. Any attempt to access it presents me with the error:

"NVIDIA Display settings are not available.
You are not currently using a display attached to an NVIDIA GPU."

I have attempted uninstalling the NVIDIA drivers and the device driver and reinstalling with both the latest and the second-latest drivers for my graphics card: (a GeForce GTX 560 Ti) with no change.

I only noticed this when I installed Mass Effect 2 on the computer through Steam: Steam warned me that the graphics card was unrecognized or not supported, though that shouldn't present a problem. I had some crashes despite my specs being more than enough for the game, which prompted me to check out the NVIDIA control panel to change some settings for the game, at which point I discovered I could not access it.

synaesthetic 2012-03-22 00:16

Boot into safe mode and completely remove the GPU drivers and all their associated registry entries (there are tools that do this, Driver Cleaner being the most prominent). When you finish doing that, reboot into normal Windows and install the latest driver from nvidia's website.

Rising Dragon 2012-03-22 02:06

Did that and I still had the issue. Finally regained access after disabling the onboard GPU. What I don't understand is why that was the key to accessing it--I'd accessed it plenty of times in the past when the onboard graphics were enabled.

sa547 2012-03-22 02:43

Wondering if the board's BIOS got updated. Also, I think it would also be necessary to run Memtest and Video Memory Stress Test to check up both system and video memory for any possible damage. Furthermore, have you tried to downgrade your card's Forceware, to see if there are any possible compatibility discrepancies?

Rising Dragon 2012-03-22 03:55

Um... I don't know how to go about running Memtest and VMST. And I have no idea what Forceware is; I'll need some help going about that.

sa547 2012-03-22 04:34

Both Memtest86 and VMST can be burned to a blank disc, then booted up (DVD drive first) to run. Forceware is another name I use to describe nVidia VC drivers. Driver downgrading is usually performed when a game can't work with the latest drivers (for example I had upped the Forceware to the latest (285) for my Geforce 6200A back then, then tried to run my favorite MMO but met a BSOD instead, so I downgraded to version 195 and it worked nicely).

Rising Dragon 2012-03-22 11:53

I've got no way of burning things onto a disc at the moment, so Memtest and VMST aren't options atm.

synaesthetic 2012-03-22 15:37


Originally Posted by Rising Dragon (Post 4066396)
I've got no way of burning things onto a disc at the moment, so Memtest and VMST aren't options atm.

Use unetbootin and make a bootable USB flash drive.

Vexx 2012-03-23 00:45

The thing that might be happening is that the module crashes very ungracefully if you tried to access a page to a piece of hardware that either doesn't exist or is disabled (like 3d vision). The next time you start the panel it tries to go to the last page you had up and of course, crashes immediately again. The only fix I've found is to rummage deep in the registry and remove the "last page' keys so that the panel will start at the home page again. Then, naturally you have to remember not to click that tab or link again.

To those who have the same problem, here's my understanding to the problem and my solution.


Originally Posted by nvidia tech support
Basically what happen is that you have clicked on a page in the control panel that is currently malfunctioning (for whatever reason). That page causes the control panel to crash, and the worse part is, control panel remembers the last page you used and will try to open that page the next time you start the control panel, so the same malfunctioning page causes the crash over and over.

To temporarily fix the problem, run regedit.exe, go to "HKEY_CURRENT_USER\Software\NVIDIA Corporation\NVControlPanel2\Client", and delete the "LastPage" entry. This will reset the control panel to its homepage, so that you won't encounter a forced crash as you start the control panel.

To completely fix the problem, you have to some how make that malfunctioning page work (by re-installing the corresponding utility), or just get rid of the page for good (by uninstalling the corresponding utility). I have experienced this problem caused by the page related to nTune, and I fixed it by re-installing it, and I have also experienced this problem caused by the "update" page, and the solution is simply uninstall the "NVIDIA System Update" thing (the update system is now replaced by something else anyway).

I've also been told its important to check for mobo updates whenever you update your video driver.

Rising Dragon 2012-04-03 23:32

Ended up regaining access only after disabling onboard graphics. However, that disabled the monitor I was using as it could only connect to that monitor from the mobo at the time. Got an adapter to fix that though.

Jaden 2012-04-04 10:44

It's not a notebook with hybrid graphics, right? Just saying, because the same thing happened to me once as I was updating nvidia drivers on such a machine.

Rising Dragon 2012-04-04 13:03

No, it's a custom-built desktop. I don't like messing with laptops; seem to have nothing but problems with them.

Rising Dragon 2012-05-02 13:39

Well, my NVIDIA control panel has disappeared again. Except this time I'm not getting any error message; it's just not appearing whatsoever.

Vexx 2012-05-02 16:26


Originally Posted by Rising Dragon (Post 4141819)
Well, my NVIDIA control panel has disappeared again. Except this time I'm not getting any error message; it's just not appearing whatsoever.

I'll read that as
1) its a choice in the menu (r-click on screen)
2) but when pressed nothing happens.
3) Checking the task manager, no sign of the process (even as a zombie)

Rising Dragon 2012-05-02 16:29

There were three NVIDIA-related processes, two of which were duplicates, none of which were the nvtray.exe process for the panel. I reinstalled the driver I was using and it's back, but there's nothing saying whatever happened won't happen again.

Vexx 2012-05-02 16:47

Yeah, you probably had a "zombie nvidia" lurking, rather like what FireFox and some other applications do once in a while ("I terminated but wait, I'm still alive! but not! Zombie!").
In Firefox's case, it just means everything gets really slow, stupid, failish.
In the case of Nvidia, its smart/dumb enough to say, "oh there's already a process named me, I don't need to start". Meanwhile, zombie process says "durrrrr".

I call this the Land of Non-Critical Computing, home of Microsoft where everything is solved by rebooting. (Software not suggested for use on deep space probes or cruise missiles)

Rising Dragon 2012-05-02 16:50

Well, those two identical processes are still there even after the driver reinstall.

nvvsvc.exe, listed as "NVIDIA Driver Helper Service, Version 285.62". One of them is a bigger file size than the other. 3,012 K and 4,844 K.

Vexx 2012-05-02 16:55

Hmmm, I have
nvtray.exe "Nvidia Settings"
nvvsvc.exe "<empty field>"
nvxdsync.exe "<empty field>"

o.O .... sigh. You might try totally uninstalling the nvidia components and rebooting, then reinstalling them? If you've already done that, then I'm stuck.

Rising Dragon 2012-05-02 16:57

Like I said, I regained access to my control panel with the reinstall already. I have nvxdsync.exe as well, listed as NVIDIA User Experience Driver Component.

Vexx 2012-05-02 19:22

Ah, I misunderstood, well then good :)

All times are GMT -5. The time now is 19:01.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.