View Single Post
Old 2006-02-10, 19:01   Link #3
suguru
京都 ikitai~
 
 
Join Date: Jan 2004
Location: massugu
Thanks for putting this up--since on OS X CCCP isn't an option, it's nice to see a guide to get MPlayer up and running. I couldn't get the cvs commands to work (it prompted me for a password, then dumped me to the command line without doing anything), but I downloaded the source for MPlayer-1.0pre7try2 from the MPlayer site, and ran the configure and make commands you gave in that directory, and the result is an actually working MPlayer.

Unfortunately, I can't seem to get MPlayer to play nice with softsubs and H.264, which are my two biggest issues with VLC (VLC plays softsubs, but if there's more than one on screen at the same time, it displays them on top of each other, which makes them more than a little hard to read...). I tried specifying the flag for softsubs, and mplayer reports it'll display it, but no subs appear on screen. The subs work fine on a PC running Zoom Player w/ the CCCP pack, so I'm pretty sure it's not the file's fault:

Code:
$ ./mplayer -sid 1 '/Volumes/nara/Binchou-tan/Binchou-tan 2.mkv'
MPlayer 1.0pre7try2-3.3 (C) 2000-2005 MPlayer Team
AltiVec found
CPU: PowerPC

Playing /Volumes/nara/Binchou-tan/Binchou-tan 2.mkv.
[mkv] Track ID 1: video (V_MS/VFW/FOURCC), -vid 0
[mkv] Track ID 2: audio (A_MPEG/L3), -aid 0, -alang jpn
[mkv] Track ID 3: subtitles (S_TEXT/ASS), -sid 0, -slang eng
[mkv] Track ID 4: subtitles (S_TEXT/UTF8), -sid 1, -slang eng
[mkv] Will play video track 1
[mkv] Will play audio track 2
[mkv] Will display subtitle track 4
Matroska file format detected.
VIDEO:  [DIVX]  640x480  16bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)
Trying to play H.264 mplayer detects it correctly--but promptly crashes.

Code:
$ ./mplayer '/Volumes/nara/Kamichu/Kamichu 6.mkv'
MPlayer 1.0pre7try2-3.3 (C) 2000-2005 MPlayer Team
AltiVec found
CPU: PowerPC

Playing /Volumes/nara/Kamichu/Kamichu 6.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_VORBIS), -aid 0, -alang jpn
[mkv] Track ID 3: subtitles (S_TEXT/ASS), -sid 0, -slang eng
[mkv] Track ID 4: subtitles (S_TEXT/UTF8), -sid 1, -slang eng
[mkv] Will play video track 1
[mkv] Will play audio track 2
Matroska file format detected.
VIDEO:  [1cva]  704x480  24bpp  23.810 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [libvorbis] Ogg/Vorbis audio decoder
AUDIO: 48000 Hz, 2 ch, s16be, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [vorbis] afm:libvorbis (OggVorbis Audio Decoder)
==========================================================================
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm:ffmpeg (FFmpeg H.264)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16be -> 48000Hz/2ch/s16be...
AF_pre: 48000Hz/2ch/s16be
AO: [macosx] 44100Hz 2ch floatbe (4 bps)
Building audio filter chain for 48000Hz/2ch/s16be -> 44100Hz/2ch/floatbe...
Starting playback...
[h264 @ 0x4540c8]QP -20 out of range
Error while decoding frame!
A:   0.4 V:   0.2 A-V:  0.254 ct:  0.000   1/  1 ??% ??% ??,?% 0 0                                    

MPlayer interrupted by signal 10 in module: decode_video
- MPlayer crashed. This shouldn't happen.
Aargh...oh well, if you happen to know a fix give me a yell, but thanks for your info in any case. I wish I could use the binary of mplayer for OS X on the mplayer site but it crashes at startup, probably doesn't like OS X 10.3.9.
suguru is offline