View Single Post
Old 2010-05-31, 06:05   Link #2
JEEB
Bishoujo fanatic
*Fansubber
 
 
Join Date: May 2007
Location: Finland / Japan
Your computer is just a bit more powerful than the TL-50 I used to have on an XP system, so having playback problems on a bit "heavier" system such as Vista is not exactly unnatural.
  • First of all, remove all codec packs and such and re-install CCCP so that all settings are reset. Try to play it back (in the included MPC-HC).
  • If not acceptable, open the CCCP settings app and enable 'MT' instead of 'H.264' (it's the multithreaded H.264 decoder, and yes -- it's set up a bit weirdly, but IIRC someone (*cough* Lord *cough*) just wanted to win space over anything else so it was done like that). Try to play it back once more. If you have an nvidia video chip on the laptop, try setting the renderer to Haali's from the default EVR-CP as mentioned here (just in case you're being hit by a problem with certain nvidia drivers and/or certain other components).
  • If it still doesn't work, try the 2010-05-21 beta from here. The betas already have automatic multithreading on on CPUs that have >1 core and have updated components. The ffmpeg in ffdshow, f.ex. has been quite updated since the last release (there was quite some speedup on H.264 decoding around after the change in years). Try playing the release back.
  • If it still doesn't work, it just means that your laptop isn't fast enough for it. Or that your environment is broken. Or the file is broken. You can always diagnose the problem with the CCCP insurgent. Make a test render and a full log -- and post that in code tags here, or onto the CCCP pastebin while linking to the bin here. It would help coming to some kind of conclusion.
__________________
I'm human, no debug | Unofficial x264 builds
JEEB is offline