AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > Support > Tech Support

Notices

Reply
 
Thread Tools
Old 2011-04-07, 19:32   Link #1
Hyperion
Black Lagoon Social Club
 
 
Join Date: Dec 2003
Location: North Carolina
Age: 33
Question What did AMD do to their GPU drivers?

For the past 2 releases of their drivers, 11.2 and now 11.3, anytime I view Flash or MS Silverlight content (ie YouTube, Netflix, Hulu, etc.) my GPU, an AMD Radeon 5850 TOXIC, maxes out to 100% for everything until the system becomes unstable or I reboot.

This is getting quite irritating because if I watch something on Netflix, I have to reboot so I can play a game. If I try to play without rebooting, the load times increase to almost staggering times. I tried loading Bad Company 2, and instead of taking 45 seconds to load to the menu, it took 3.5 minutes.

I've tried reinstalling the drivers many times. I'll uninstall using AMD's uninstall tool, reboot, then run drivercleaner.net to clean out the remaining files, then run CCleaner to get any leftover registry entry's, then install the new drivers.

I can't get the ATI CCC to work with the 11.3 drivers. I'm using either MSI Afterburner or ATI Tray Tools just to adjust settings on my card.

I'd revert to the 10.x drivers, but most of their later releases caused flash content to crash the browser, or shut down the driver and restart it.

Seriously, what did they break and how do I fix it? I've looked around on the official AMD forums, and people seem to be having all sorts of problems. And no official word from AMD on what's going on.
__________________
Hyperion is offline   Reply With Quote
Old 2011-04-07, 20:34   Link #2
liquidmetal
procrastinating...
 
 
Join Date: Aug 2010
Think for the flash problem just disable flash hardware acceleration. Should stop the crashing.

In terms of unable to reinstall the drivers I would personally point at drivercleaner.net. There have been problems where driversweeper/drivercleaner programs tend to delete more than they are supposed to with AMD drivers.

Would advise to revert to the 10.x catalysts, use the above flash fix and then reinstall the latest 11.3s. When installing the latest, just install over the top of the last ones. Maybe check the 'clean install' option if there is one but do not bother with drivercleaner.

If that is working fine then if you really want to uninstall and reinstall for a full 'clean install' then do so but again miss out the drivercleaner step.

Post back if it works
liquidmetal is offline   Reply With Quote
Old 2011-04-07, 22:43   Link #3
blaze0041
a.k.a. Flammenkrieg
*IT Support
 
 
Join Date: Apr 2009
Location: Down under...
Just on the Flash issue, what version of Flash are you using? (Latest is: 10.2.153.1)
__________________
You Watanabe (Love Live! Sunshine!!)
"Make sure you do a good job with your life's blueprint." - Kanna Makino
blaze0041 is offline   Reply With Quote
Old 2011-04-08, 00:02   Link #4
Hyperion
Black Lagoon Social Club
 
 
Join Date: Dec 2003
Location: North Carolina
Age: 33
Quote:
Originally Posted by liquidmetal View Post
Think for the flash problem just disable flash hardware acceleration. Should stop the crashing.

In terms of unable to reinstall the drivers I would personally point at drivercleaner.net. There have been problems where driversweeper/drivercleaner programs tend to delete more than they are supposed to with AMD drivers.

Would advise to revert to the 10.x catalysts, use the above flash fix and then reinstall the latest 11.3s. When installing the latest, just install over the top of the last ones. Maybe check the 'clean install' option if there is one but do not bother with drivercleaner.

If that is working fine then if you really want to uninstall and reinstall for a full 'clean install' then do so but again miss out the drivercleaner step.

Post back if it works
I'll give this a shot.

Quote:
Originally Posted by blaze0041 View Post
Just on the Flash issue, what version of Flash are you using? (Latest is: 10.2.153.1)
That's the version I'm using. I did turn off hardware acceleration for flash and it seemed to fix several problems I was having with it.
__________________
Hyperion is offline   Reply With Quote
Old 2011-04-08, 03:18   Link #5
synaesthetic
blinded by blood
*Author
 
 
Join Date: Jun 2009
Location: Oakland, CA
Age: 34
Send a message via AIM to synaesthetic
They screwed them. CCC profiles aren't even working properly in 11.3, so I'm still using 10.11. Without CCC profiles, I get screwed because PowerPlay is tuned crappy for my GPU--it idles at 405/1000! Kills my battery! Makes the fan come on all the time!

With 10.11 and CCC profiles I can idle my 5850 at 100/150 and my battery life is just about four hours with this 9-cell monstrosity (even with a CCFL backlit LCD and a full-voltage i5).
__________________
synaesthetic is offline   Reply With Quote
Old 2011-04-09, 12:44   Link #6
Hyperion
Black Lagoon Social Club
 
 
Join Date: Dec 2003
Location: North Carolina
Age: 33
Quote:
Originally Posted by liquidmetal View Post
Think for the flash problem just disable flash hardware acceleration. Should stop the crashing.

In terms of unable to reinstall the drivers I would personally point at drivercleaner.net. There have been problems where driversweeper/drivercleaner programs tend to delete more than they are supposed to with AMD drivers.

Would advise to revert to the 10.x catalysts, use the above flash fix and then reinstall the latest 11.3s. When installing the latest, just install over the top of the last ones. Maybe check the 'clean install' option if there is one but do not bother with drivercleaner.

If that is working fine then if you really want to uninstall and reinstall for a full 'clean install' then do so but again miss out the drivercleaner step.

Post back if it works
Well that didn't work. Even tried going to the 11.4 beta drivers. Guess I'll roll back to the 10.7's and see if that works. If it doesn't, I'll see what kind of warranty Sapphire has on these cards and see if I can RMA it.
__________________
Hyperion is offline   Reply With Quote
Old 2011-04-09, 13:19   Link #7
liquidmetal
procrastinating...
 
 
Join Date: Aug 2010
So are the older 10.xx series of catalysts working then?

When you say you can't get the ATI CCC to work with the newer 11.xx catalysts does that mean you are only uninstalling the drivers and not the whole command suite?
liquidmetal is offline   Reply With Quote
Old 2011-04-10, 03:06   Link #8
Hyperion
Black Lagoon Social Club
 
 
Join Date: Dec 2003
Location: North Carolina
Age: 33
I do a total uninstall. When I say the CCC doesn't work, I mean that it doesn't show in the taskbar, nor does it open via right click desktop and clicking ATI CCC. The desktop method just causes my screen to fritz out for a second.

And I haven't installed the 10.xx drivers yet. Been too busy today.
__________________
Hyperion is offline   Reply With Quote
Old 2011-04-10, 09:37   Link #9
MeoTwister5
Komrades of Kitamura Kou
 
 
Join Date: Jul 2004
Age: 33
These drivers pretty much overheated my motherboard on my new laptop, and now I have to wait 2-4 weeks for Asus' replacement. When it come back I'm sticking with the Asus stock drivers with the installer CD from 2010.
MeoTwister5 is offline   Reply With Quote
Old 2011-04-10, 13:52   Link #10
synaesthetic
blinded by blood
*Author
 
 
Join Date: Jun 2009
Location: Oakland, CA
Age: 34
Send a message via AIM to synaesthetic
Don't use the stock ones, they're not very good. If you have a 5xxx series mGPU, use the 10.11 Catalyst Mobility drivers. They're rock-stable and have no problems at all; I've been using them for a while now.

Catalyst Mobility 10.11 64-bit
Catalyst Mobility 10.11 32-bit
__________________
synaesthetic is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 21:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
We use Silk.