AnimeSuki Forums

Register Forum Rules FAQ Members List Social Groups Search Today's Posts Mark Forums Read

Go Back   AnimeSuki Forum > Support > Tech Support > Playback Help

Notices

 
 
Thread Tools
Old 2007-02-08, 08:21   Link #21
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
If you are on Linux, install the ALSA dev packages. If you are on MacOS X, I dunno what.
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
Old 2007-02-10, 22:18   Link #22
gunbladex
jus a doooooood~
 
Join Date: Feb 2007
Location: Singapore
Question

hey guys kinda new here, um i jus downloaded code geass from gg fansubs and they recommend using this mplayer thingy.
question: how do i install it?
im using windows xp so the linux and Mac OS X thing doesnt apply to me right?
i've downloaded MPlayer 1.0rc1 Windows, a skin and the cccp thingy as well. but after i extracted the files i cant run Mplayer.
i think im gona delete everything and start from scratch can someone point me in the right directions please?
gunbladex is offline  
Old 2007-02-11, 01:48   Link #23
Nicholi
King of Hosers
 
Join Date: Dec 2005
Age: 35
CCCP, as in the Combined Community Codec Pack, is a DirectShow codec pack. Which has no effect whatsoever on mplayer (or VLC) because it uses internal codecs. If you want to use the CCCP, you do not need mplayer. You should be able to use any DirectShow player, such as WMP, however we recommend using Media Player Classic (MPC, unrelated to Microsoft products) or ZoomPlayer which come with the pack itself.

If however you do want to use a mplayer build for windows, we have our own found here. mplayer is a command-line player, so you don't run it like normal players. You can make a shortcut and drag videos to the shortcut, which I believe works. Also there are a few nice frontends for it in win32, which would make it act more normally, such as MPUI.
Nicholi is offline  
Old 2007-02-11, 04:27   Link #24
gunbladex
jus a doooooood~
 
Join Date: Feb 2007
Location: Singapore
Thumbs up

thanx alot dude! media player classic is great! i see the subs now
gunbladex is offline  
Old 2007-02-17, 11:29   Link #25
Epyon9283
Geek
 
 
Join Date: Dec 2005
Location: New Jersey
Age: 35
Send a message via ICQ to Epyon9283 Send a message via AIM to Epyon9283
Quote:
Originally Posted by Ergzay View Post
Could you please run 'freetype-config --ftversion' and 'ls /usr/X11**/*fontconfig*' and tell me the veresion of Mac OS X you have. I need this information to complete the ---TO BE COMPLETED--- section in my guide.
10.4.8 (intel):
iMac:~ tom$ freetype-config --ftversion
2.1.10
iMac:~ tom$ ls /usr/X11R6/lib/*fontconfig*
/usr/X11R6/lib/libfontconfig.1.0.dylib /usr/X11R6/lib/libfontconfig.a
/usr/X11R6/lib/libfontconfig.1.dylib /usr/X11R6/lib/libfontconfig.dylib
Epyon9283 is offline  
Old 2007-02-28, 16:49   Link #26
Niji
Senior Member
 
Join Date: Sep 2006
Could someone tell me please how I switch audio tracks on mplayer on OSX? I pressed all available keys to no avail (j does subtitles, that works fine)
Niji is offline  
Old 2007-02-28, 17:13   Link #27
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
Quote:
Originally Posted by Niji View Post
Could someone tell me please how I switch audio tracks on mplayer on OSX? I pressed all available keys to no avail (j does subtitles, that works fine)
Use -alang jpn (or eng) or -aid 0 (or 1, or 2, or whatever) on the commandline. You can't switch audio tracks while playing.
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
Old 2007-03-04, 12:04   Link #28
blueorange
Junior Member
 
Join Date: Jul 2006
Quote:
Originally Posted by Niji View Post
Could someone tell me please how I switch audio tracks on mplayer on OSX? I pressed all available keys to no avail (j does subtitles, that works fine)
Press # (which is alt-3)

This works for me on MPlayer on the Mac. It only works on .mkv files though.

If you want to change the audio on .ogm files you will need to what TheFluff says.
blueorange is offline  
Old 2007-03-05, 06:24   Link #29
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
Oh, right, they fixed that.
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
Old 2007-03-25, 15:36   Link #30
Starks
I see what you did there!
*Scanlator
 
 
Join Date: Apr 2004
Age: 31
Send a message via AIM to Starks
I compiled my own MPlayer from an SVN build, but I have a problem...

The video won't play in its proper aspect ratio and changing the options has no effect. All videos are stretched to 16:9.

Edit: None of the X11 drivers selectable work properly, one gives me the proper AR but no fullscreen, the other gives give me the wrong AR and fullscreen, the third simply doesn't work.
__________________

Last edited by Starks; 2007-03-25 at 15:52.
Starks is offline  
Old 2007-03-25, 17:41   Link #31
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
Try (in order, not all at the same time):

-monitoraspect <your monitor aspect ratio>
-monitorpixelaspect 1 (or 0, read the manpage)
-nokeepaspect
-screenh <monitor resolution height in pixels> -screenw <monitor resolution width in pixels>
-fstype (read the manpage for details)
-vo gl2 (if you have it compiled in)
-vo fbdev (if you have it compiled in and supported in the kernel)
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
Old 2007-03-25, 18:32   Link #32
Starks
I see what you did there!
*Scanlator
 
 
Join Date: Apr 2004
Age: 31
Send a message via AIM to Starks
Quote:
Originally Posted by TheFluff View Post
Try (in order, not all at the same time):

-monitoraspect <your monitor aspect ratio>
-monitorpixelaspect 1 (or 0, read the manpage)
-nokeepaspect
-screenh <monitor resolution height in pixels> -screenw <monitor resolution width in pixels>
-fstype (read the manpage for details)
-vo gl2 (if you have it compiled in)
-vo fbdev (if you have it compiled in and supported in the kernel)
BINGO! That solved the fullscreen and aspect ratio problems.

Thanks. I'll put that in my config.
__________________
Starks is offline  
Old 2007-04-15, 19:47   Link #33
fyleow
Junior Member
 
Join Date: Apr 2007
I'm using Ubuntu Feisty and I'm having issues with Mplayer. The video is not as smooth as it is using CCCP under Windows. For example in Hayate no Gotoku episode 2 by Eclipse it's a little jerky when the numbers are scrolling by at around 11 seconds into the video. At around 28 seconds when it shows Nagi the video is not smooth either.

CPU utilization doesn't seem to be the issue here (C2D 3.0 ghz), and my HDDs are running DMA.

If I use VLC the video is smooth, almost as good as MPC in Windows but VLC support for soft subs is just terrible.

Any ideas?
fyleow is offline  
Old 2007-04-15, 20:45   Link #34
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
Which video output driver are you using?
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
Old 2007-04-15, 21:38   Link #35
fyleow
Junior Member
 
Join Date: Apr 2007
x11 X11 (XImage/Shm).

I do have Beryl but I have an Nvidia card so I'm not running on XGL or AIXGL
fyleow is offline  
Old 2007-04-19, 00:09   Link #36
SeijiSensei
AS Oji-kun
 
 
Join Date: Nov 2006
Location: In your bloodstream
Age: 68
Some HD encodes crash my players

After considerable massaging, I've been able to configure our new Dell 640m laptop to play some, but not all, HD fansubs. In particular, the Arienai encodes of Hataraki Man play cleanly, but the Lunar encodes of Bartender do not. I've tried using both mplayer and xine to play the Bartender episodes, and both players crash about nine seconds after the file opens during the voice-over describing the theme of that week's episode.

I'm running a fully-updated version of Fedora Core 6. The laptop has an Intel 945GM video adapter, and I'm using a current release of the i810 driver from x.org which supports all the recent Intel adapters. I've added the following options to xorg.conf
Code:
Options     "VideoRam" "131072"
Options     "CacheLines" "1980"
which eliminated some earlier problems where X was unable to determine the correct amount of available video memory. I'm also using the 915resolution hack to set the screen mode to 1280x800 and have added "ModeLines" to the Monitor section for the 1280x800 mode. I also have "monitoraspect=16:10" in mplayer.conf to eliminate stretching when playing a 4:3 video; xine doesn't seem to require this.

Running midentify against both files produces the following output:
Spoiler for Hataraki Man:


Spoiler for Bartender:


They both have "video format" of avc1 and a video codec of ffh264. They differ in some respects -- the "demuxer" is "mov" (i.e., Quicktime) for Hataraki Man and "mkv" (Matroska) for Bartender. The audio formats are also different -- mp4a for Hataraki Man and mp3 for Bartender. While my knowledge of the ins-and-outs of encoding is somewhat limited, these minor differences don't seem to explain why one file plays correctly while the other causes both players to crash.

I've spent a considerable amount of time searching the Internet to find the right tweaks to use the i945 card to its fullest. I'm pretty sure I've incorporated all the correct settings for both xorg.conf and the players themselves. The Hataraki Man episodes look terrific in this format, clearly superior to the Xvid re-encodes I made earlier using mencoder at the same 720p resolution. I just can't seem to figure out what it is about the Bartender encodes that crashes my players. My similarly re-encoded Xvid versions of the Bartender files do not cause this problem. They even play on my Cowon A2 media player that has DivX/Xvid support. It just seems to be the H.264 originals that don't work correctly.

Any ideas?
SeijiSensei is offline  
Old 2007-04-19, 06:23   Link #37
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
I wish all people with questions about playback problems could include this much info... but you forgot one thing: MPlayer and Xine versions?
Also, can you include the error message when running MPlayer -v?
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
Old 2007-04-19, 15:30   Link #38
SeijiSensei
AS Oji-kun
 
 
Join Date: Nov 2006
Location: In your bloodstream
Age: 68
Quote:
Originally Posted by TheFluff View Post
I wish all people with questions about playback problems could include this much info
After dealing with "questions" like "oh, my email isn't working" a few dozen times, I tend to make sure I include a lot of information in my requests for help

Quote:
... but you forgot one thing: MPlayer and Xine versions?
Also, can you include the error message when running MPlayer -v?
Of course, I can always forget the basics! I use the Livna builds of these players:

mplayer-1.0-0.72.20070325svn.lvn6
xine-0.99.4-10.lvn6
xine-lib-1.1.5-1.fc6
xine-lib-extras-1.1.5-1.fc6
xine-lib-extras-nonfree-1.1.5-1.lvn6

I install and update using "yum" so it manages all the dependencies for me. The dependency list for mplayer alone totals some 75 libraries.

I've posted the complete verbose output from mplayer on a web server I maintain. For Bartender, the output is here. The corresponding output for Hataraki Man is here.

I think the error in question is probably related to these:
ds_fill_buffer: EOF reached (stream: audio)
ds_fill_buffer: EOF reached (stream: video)

I did some searching for these errors at Google, but it only turned up copies of the mplayer source code. I didn't really find anything all that helpful as an end-user.

Thanks in advance, Fluff, for any help you can offer.
SeijiSensei is offline  
Old 2007-04-20, 05:59   Link #39
TheFluff
Excessively jovial fellow
 
 
Join Date: Dec 2005
Location: ISDB-T
Age: 32
What I immediately think when I see those errors is "corrupted file". I'm assuming you did CRC-check the files?
If it's not that, there's not really anything that comes to mind immediately. Try doing a disk check, or see if your Matroska libraries are outdated and/or incorrectly installed.
__________________
| ffmpegsource
17:43:13 <~deculture> Also, TheFluff, you are so fucking slowpoke.jpg that people think we dropped the DVD's.
17:43:16 <~deculture> nice job, fag!

01:04:41 < Plorkyeran> it was annoying to typeset so it should be annoying to read
TheFluff is offline  
 

Tags
wiki candidate

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
We use Silk.